summaryrefslogtreecommitdiff
path: root/gnu/packages/sagemath.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-16 14:01:58 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:59 +0100
commit7c1f1d9f4bc77392db425a2dd9d117f688542a10 (patch)
tree3841d2c689aed4d2e805482473a8b9fa0e809b2f /gnu/packages/sagemath.scm
parentd42e59c5750644a572eff6ebbf820e18345f45ac (diff)
gnu: python-pplpy: Add missing inputs.
* gnu/packages/sagemath.scm (python-pplpy)[native-inputs]: Add python-setuptools and python-wheel. Change-Id: I1da4130ddedeefbe71ae07c3885ae0e5fa1f8204
Diffstat (limited to 'gnu/packages/sagemath.scm')
-rw-r--r--gnu/packages/sagemath.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index f4142b37bf..9e78bd1ced 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2020 Jakub Kądziołka <[email protected]>
;;; Copyright © 2021 Efraim Flashner <[email protected]>
;;; Copyright © 2024 Vinicius Monego <[email protected]>
+;;; Copyright © 2025 Ricardo Wurmus <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -274,7 +275,11 @@ libraries GMO, MPFR and MPC.")
(sha256
(base32 "1zggfj09zkfcabcsasq27vwbhdmkig4yn380gi6wykcih9n22anl"))))
(build-system pyproject-build-system)
- (native-inputs (list python-cython-3 python-pytest))
+ (native-inputs
+ (list python-cython-3
+ python-pytest
+ python-setuptools
+ python-wheel))
(inputs (list gmp mpc mpfr pari-gp ppl))
(propagated-inputs (list python-cysignals python-gmpy2))
(home-page "https://github.com/sagemath/pplpy")