summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorJelle Licht <[email protected]>2025-03-10 12:54:32 +0100
committerSharlatan Hellseher <[email protected]>2025-03-10 22:42:27 +0000
commit42773718d5d5d42137ac84826850256fd6bed606 (patch)
treeda442fdd3d4705aeea3466c2fb9779b0957cb60a /gnu/packages/python-xyz.scm
parent88eaa9e7262481eea79ae4fe45fcc5882160750a (diff)
gnu: python-numba: Disable tests that are not reproducible.
Fixing #76260: Non-deterministic test failure in python-numba 0.61.0 * gnu/packages/python-xyz.scm (python-numba) [phases] {disable-failing-tests}: Adjust the phase to skip some additional tests that can fail depending on current CPU. Change-Id: I67f3a100f5863f6d946a8d07428e802178bd7391 Reported-by: Ludovic Courtès <[email protected]> Reviewed-by: Greg Hogan <[email protected]> Signed-off-by: Sharlatan Hellseher <[email protected]>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9f2829c4a8..4cb7c72a82 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29988,6 +29988,29 @@ validation testing and application logic.")
(substitute* "numba/tests/test_import.py"
(("def test_no_accidental_warnings")
"def disabled_test_no_accidental_warnings"))
+ ;; These tests fail due to result rounding depending on CPU.
+ (substitute* "numba/tests/test_looplifting.py"
+ (("def test_lift_objectmode_issue_4223")
+ "def disabled_test_lift_objectmode_issue_4223"))
+ (substitute* "numba/tests/test_extending.py"
+ (("def test_series_ufunc")
+ "def disabled_test_series_ufunc")
+ (("def test_index_ufunc")
+ "def disabled_test_index_ufunc"))
+ (substitute* "numba/tests/test_array_exprs.py"
+ (("def test_explicit_output")
+ "def disabled_test_explicit_output"))
+ (substitute* "numba/tests/test_target_extension.py"
+ (("def test_basic_offload")
+ "def disabled_test_basic_offload"))
+ (substitute* "numba/tests/test_np_functions.py"
+ (("def test_windowing")
+ "def disabled_test_windowing"))
+ ;; This fails nondeterministically, possibly depending on CPU.
+ ;; https://github.com/numba/numba/issues/8282.
+ (substitute* "numba/tests/test_function_type.py"
+ (("def test_wrapper_address_protocol_libm")
+ "def disabled_test_wrapper_address_protocol_libm"))
;; Some tests timeout or crash on some architectures.
,@(cond
((target-aarch64?)