summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorEvgeny Pisemsky <[email protected]>2025-03-10 18:36:14 +0300
committerSharlatan Hellseher <[email protected]>2025-03-11 20:01:16 +0000
commit0cbc54c162fd4936438960d47830920f26be7238 (patch)
tree4fec250f0c9ca9007c33ce257fc1edac64c1e221 /gnu/packages/python-xyz.scm
parent8f844e6af095fa86871474150700068a114af9fa (diff)
gnu: Add python-shxparser.
* gnu/packages/python-xyz.scm (python-shxparser): New variable. Change-Id: Iaa4bdc216f0e06595237d6fb8e5ee138797605bc Signed-off-by: Sharlatan Hellseher <[email protected]>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4cb7c72a82..cf1b5e22ae 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -663,6 +663,29 @@ processes, in parallel, in the console, with an interactive TUI.")
edit distance algorithm for Python in Cython for high performance.")
(license license:bsd-3)))
+(define-public python-shxparser
+ (package
+ (name "python-shxparser")
+ (version "0.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "shxparser" version))
+ (sha256
+ (base32 "0w7j5ywskandp91v74966pw1pvq9d5zrx5gkjcn84xi8wsyf8hc5"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-svgelements
+ python-setuptools
+ python-wheel))
+ (home-page "https://github.com/tatarize/shxparser")
+ (synopsis "SHX line font parser")
+ (description
+ "This is a pure python parser for SHX Hershey font files that are an
+AutoCad format which can encode single line fonts. This format is used for
+many CNC and laser operations.")
+ (license license:expat)))
+
(define-public python-takethetime
(package
(name "python-takethetime")