summaryrefslogtreecommitdiff
path: root/gnu/packages/python-compression.scm
diff options
context:
space:
mode:
authorMarius Bakke <[email protected]>2020-01-03 19:41:05 +0100
committerMarius Bakke <[email protected]>2020-01-03 19:41:05 +0100
commit982eff9e841f3539e4ecf93669435a290bfde571 (patch)
treeb1e3f6fc85c6c35c264f091eb2fc5cff8514c230 /gnu/packages/python-compression.scm
parent7ba6d70e4528201151195e1ed2175ee4828bdb2f (diff)
parent7158fe4ded47a599ceb8d556132ba83fcc686962 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/python-compression.scm')
-rw-r--r--gnu/packages/python-compression.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-compression.scm b/gnu/packages/python-compression.scm
index 705a7ffa3b..0f2bc78c12 100644
--- a/gnu/packages/python-compression.scm
+++ b/gnu/packages/python-compression.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2017 ng0 <[email protected]>
;;; Copyright © 2017 Julien Lepiller <[email protected]>
;;; Copyright © 2018, 2019 Efraim Flashner <[email protected]>
+;;; Copyright © 2020 Nicolas Goaziou <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -234,3 +235,23 @@ install: libbitshuffle.so
"This package provides a @code{pathlib}-compatible @code{Zipfile} object
wrapper. It provides a backport of the @code{Path} object.")
(license license:expat)))
+
+(define-public python-zstandard
+ (package
+ (name "python-zstandard")
+ (version "0.13.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "zstandard" version))
+ (sha256
+ (base32 "0q9msi00s93iqm8vzd839r7yc51gz54z90h5bckqyjdxa6vxijz5"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-hypothesis" ,python-hypothesis)))
+ (home-page "https://github.com/indygreg/python-zstandard")
+ (synopsis "Zstandard bindings for Python")
+ (description "This project provides Python bindings for interfacing with
+the Zstandard compression library. A C extension and CFFI interface are
+provided.")
+ (license license:bsd-3)))