summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLiliana Marie Prikler <[email protected]>2023-07-30 08:46:07 +0200
committerLiliana Marie Prikler <[email protected]>2023-07-30 08:46:42 +0200
commit4eca7833ef0b16fb3cdda138e3ee1e5824c36e41 (patch)
treea87586e931bd51f2e87d07b5fbdd83bce0ccaacd /gnu/packages/patches
parent4c204d01d57ac7da11a5772d5d4e3254d1c2408f (diff)
parent6a2b5c66bf57bd1bbc6300e1f99e16e65f2478e8 (diff)
Merge branch 'master' into gnome-team
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/curlftpfs-fix-error-closing-file.patch23
-rw-r--r--gnu/packages/patches/curlftpfs-fix-file-names.patch76
-rw-r--r--gnu/packages/patches/curlftpfs-fix-memory-leak.patch23
-rw-r--r--gnu/packages/patches/curlftpfs-fix-no_verify_hostname.patch27
-rw-r--r--gnu/packages/patches/lvm2-static-link.patch36
-rw-r--r--gnu/packages/patches/mutter-fix-inverted-test.patch290
6 files changed, 439 insertions, 36 deletions
diff --git a/gnu/packages/patches/curlftpfs-fix-error-closing-file.patch b/gnu/packages/patches/curlftpfs-fix-error-closing-file.patch
new file mode 100644
index 0000000000..c90b7e9094
--- /dev/null
+++ b/gnu/packages/patches/curlftpfs-fix-error-closing-file.patch
@@ -0,0 +1,23 @@
+From d27d1cd3a79959ff1eb8439b06e108149f21141f Mon Sep 17 00:00:00 2001
+From: Joseph Lansdowne <[email protected]>
+Date: Sun, 31 Mar 2019 19:26:10 +0100
+Subject: [PATCH] fix error on closing written file
+
+---
+ ChangeLog | 1 +
+ ftpfs.c | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/ftpfs.c b/ftpfs.c
+index 0346354..34f8c38 100644
+--- a/ftpfs.c
++++ b/ftpfs.c
+@@ -503,7 +503,7 @@ static void *ftpfs_write_thread(void *data) {
+
+ curl_easy_setopt_or_die(fh->write_conn, CURLOPT_URL, fh->full_path);
+ curl_easy_setopt_or_die(fh->write_conn, CURLOPT_UPLOAD, 1);
+- curl_easy_setopt_or_die(fh->write_conn, CURLOPT_INFILESIZE, -1);
++ curl_easy_setopt_or_die(fh->write_conn, CURLOPT_INFILESIZE, -1L);
+ curl_easy_setopt_or_die(fh->write_conn, CURLOPT_READFUNCTION, write_data_bg);
+ curl_easy_setopt_or_die(fh->write_conn, CURLOPT_READDATA, fh);
+ curl_easy_setopt_or_die(fh->write_conn, CURLOPT_LOW_SPEED_LIMIT, 1);
diff --git a/gnu/packages/patches/curlftpfs-fix-file-names.patch b/gnu/packages/patches/curlftpfs-fix-file-names.patch
new file mode 100644
index 0000000000..04979a3b0c
--- /dev/null
+++ b/gnu/packages/patches/curlftpfs-fix-file-names.patch
@@ -0,0 +1,76 @@
+From bc3fb45db30741a60d4e8904cbd4d6118fb85741 Mon Sep 17 00:00:00 2001
+From: Joseph Lansdowne <[email protected]>
+Date: Sun, 31 Mar 2019 19:25:26 +0100
+Subject: [PATCH] fix filenames with url-reserved characters
+
+---
+ ChangeLog | 2 +-
+ path_utils.c | 28 +++++++++++++++++-----------
+ 2 files changed, 18 insertions(+), 12 deletions(-)
+
+diff --git a/path_utils.c b/path_utils.c
+index db3d7e4..4f747bb 100644
+--- a/path_utils.c
++++ b/path_utils.c
+@@ -39,9 +39,11 @@ char* get_full_path(const char* path) {
+ path = converted_path;
+ }
+
+- ret = g_strdup_printf("%s%s", ftpfs.host, path);
++ const char *const escaped_path = g_uri_escape_string(path, "/", FALSE);
++ ret = g_strdup_printf("%s%s", ftpfs.host, escaped_path);
+
+ free(converted_path);
++ free((char *) escaped_path);
+
+ return ret;
+ }
+@@ -58,9 +60,12 @@ char* get_fulldir_path(const char* path) {
+ path = converted_path;
+ }
+
+- ret = g_strdup_printf("%s%s%s", ftpfs.host, path, strlen(path) ? "/" : "");
++ const char *const escaped_path = g_uri_escape_string(path, "/", FALSE);
++ ret = g_strdup_printf(
++ "%s%s%s", ftpfs.host, escaped_path, strlen(escaped_path) ? "/" : "");
+
+ free(converted_path);
++ free((char *) escaped_path);
+
+ return ret;
+ }
+@@ -71,24 +76,25 @@ char* get_dir_path(const char* path) {
+ const char *lastdir;
+
+ ++path;
+-
+- lastdir = strrchr(path, '/');
+- if (lastdir == NULL) lastdir = path;
+
+- if (ftpfs.codepage && (lastdir - path > 0)) {
+- converted_path = g_strndup(path, lastdir - path);
++ if (ftpfs.codepage) {
++ converted_path = g_strdup(path);
+ convert_charsets(ftpfs.iocharset, ftpfs.codepage, &converted_path);
+ path = converted_path;
+- lastdir = path + strlen(path);
+ }
+
++ const char *const escaped_path = g_uri_escape_string(path, "/", FALSE);
++ lastdir = strrchr(escaped_path, '/');
++ if (lastdir == NULL) lastdir = escaped_path;
++
+ ret = g_strdup_printf("%s%.*s%s",
+ ftpfs.host,
+- lastdir - path,
+- path,
+- lastdir - path ? "/" : "");
++ lastdir - escaped_path,
++ escaped_path,
++ lastdir - escaped_path ? "/" : "");
+
+ free(converted_path);
++ free((char *) escaped_path);
+
+ return ret;
+ }
diff --git a/gnu/packages/patches/curlftpfs-fix-memory-leak.patch b/gnu/packages/patches/curlftpfs-fix-memory-leak.patch
new file mode 100644
index 0000000000..eea801957e
--- /dev/null
+++ b/gnu/packages/patches/curlftpfs-fix-memory-leak.patch
@@ -0,0 +1,23 @@
+From 2d01202eee44d8bad5bb982e72829b4a98d58bcd Mon Sep 17 00:00:00 2001
+From: Joseph Lansdowne <[email protected]>
+Date: Thu, 4 Apr 2019 20:37:06 +0100
+Subject: [PATCH] fix memory leak
+
+---
+ ChangeLog | 1 +
+ ftpfs.c | 2 ++
+ 2 files changed, 3 insertions(+)
+
+diff --git a/ftpfs.c b/ftpfs.c
+index 34f8c38..020e559 100644
+--- a/ftpfs.c
++++ b/ftpfs.c
+@@ -607,6 +607,8 @@ static int finish_write_thread(struct ftpfs_file *fh)
+
+
+ static void free_ftpfs_file(struct ftpfs_file *fh) {
++ buf_free(&fh->buf);
++ buf_free(&fh->stream_buf);
+ if (fh->write_conn)
+ curl_easy_cleanup(fh->write_conn);
+ g_free(fh->full_path);
diff --git a/gnu/packages/patches/curlftpfs-fix-no_verify_hostname.patch b/gnu/packages/patches/curlftpfs-fix-no_verify_hostname.patch
new file mode 100644
index 0000000000..67a3e933ad
--- /dev/null
+++ b/gnu/packages/patches/curlftpfs-fix-no_verify_hostname.patch
@@ -0,0 +1,27 @@
+From b2ae7a152921bf36a39f01de43769ee90cbbd253 Mon Sep 17 00:00:00 2001
+From: Joseph Lansdowne <[email protected]>
+Date: Tue, 9 Apr 2019 21:08:32 +0100
+Subject: [PATCH] fix option `no_verify_hostname`
+
+Broke with a curl upgrade at some point. 1 is no longer a valid option
+- not sure exactly what it used to do.
+---
+ ChangeLog | 3 +++
+ ftpfs.c | 4 +---
+ 2 files changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/ftpfs.c b/ftpfs.c
+index 020e559..207d5fd 100644
+--- a/ftpfs.c
++++ b/ftpfs.c
+@@ -1627,9 +1627,7 @@ static void set_common_curl_stuff(CURL* easy) {
+ }
+
+ if (ftpfs.no_verify_hostname) {
+- /* The default is 2 which verifies even the host string. This sets to 1
+- * which means verify the host but not the string. */
+- curl_easy_setopt_or_die(easy, CURLOPT_SSL_VERIFYHOST, 1);
++ curl_easy_setopt_or_die(easy, CURLOPT_SSL_VERIFYHOST, 0);
+ }
+
+ curl_easy_setopt_or_die(easy, CURLOPT_INTERFACE, ftpfs.interface);
diff --git a/gnu/packages/patches/lvm2-static-link.patch b/gnu/packages/patches/lvm2-static-link.patch
deleted file mode 100644
index 2ade0a1aaa..0000000000
--- a/gnu/packages/patches/lvm2-static-link.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Fix static linking of 'lvm.static', which indirectly depend on libpthread
-and libm via libdevmapper.a.
-
---- LVM2.2.02.166/tools/Makefile.in 2016-11-22 21:31:15.521045149 +0100
-+++ LVM2.2.02.166/tools/Makefile.in 2016-11-22 21:31:24.085082767 +0100
-@@ -137,7 +137,7 @@
- lvm.static: $(OBJECTS) lvm-static.o $(LVMINTERNAL_LIBS)
- @echo " [CC] $@"
- $(Q) $(CC) $(CFLAGS) $(LDFLAGS) -static -L$(interfacebuilddir) -o $@ $+ \
-- $(DMEVENT_LIBS) $(STATIC_LIBS) $(LVMLIBS)
-+ $(DMEVENT_LIBS) $(STATIC_LIBS) $(LVMLIBS) $(PTHREAD_LIBS)
-
- liblvm2cmd.a: $(top_builddir)/lib/liblvm-internal.a $(OBJECTS) lvmcmdlib.o lvm2cmd.o
- @echo " [AR] $@"
---- a/make.tmpl.in 2018-07-31 22:00:39.969983104 +0200
-+++ b/make.tmpl.in 2018-07-31 22:00:58.467613682 +0200
-@@ -63,7 +63,7 @@
-
- LIBS += @LIBS@ $(SELINUX_LIBS) $(UDEV_LIBS) $(BLKID_LIBS) $(RT_LIBS) $(M_LIBS)
- # Extra libraries always linked with static binaries
--STATIC_LIBS = $(SELINUX_LIBS) $(UDEV_LIBS) $(BLKID_LIBS)
-+STATIC_LIBS = $(SELINUX_LIBS) $(UDEV_LIBS) $(BLKID_LIBS) $(M_LIBS)
- DEFS += @DEFS@
- # FIXME set this only where it's needed, not globally?
- CFLAGS ?= @COPTIMISE_FLAG@ @CFLAGS@
---- a/libdm/make.tmpl.in 2018-12-18 15:22:34.000000000 +0100
-+++ b/libdm/make.tmpl.in 2019-01-29 21:45:33.637345799 +0100
-@@ -57,7 +57,7 @@
- LIBS = @LIBS@
- LIBS += $(SELINUX_LIBS) $(UDEV_LIBS) $(BLKID_LIBS) $(RT_LIBS) -lm
- # Extra libraries always linked with static binaries
--STATIC_LIBS = $(SELINUX_LIBS) $(UDEV_LIBS) $(BLKID_LIBS)
-+STATIC_LIBS = $(SELINUX_LIBS) $(UDEV_LIBS) $(BLKID_LIBS) $(PTHREAD_LIBS) $(M_LIBS)
- DEFS += @DEFS@
- # FIXME set this only where it's needed, not globally?
- CFLAGS ?= @COPTIMISE_FLAG@ @CFLAGS@
diff --git a/gnu/packages/patches/mutter-fix-inverted-test.patch b/gnu/packages/patches/mutter-fix-inverted-test.patch
new file mode 100644
index 0000000000..3676b31def
--- /dev/null
+++ b/gnu/packages/patches/mutter-fix-inverted-test.patch
@@ -0,0 +1,290 @@
+From 5a83e8ef8250526a40e8e69c6398f990ab482b2f Mon Sep 17 00:00:00 2001
+From: Olivier Fourdan <[email protected]>
+Date: Fri, 2 Jun 2023 14:42:51 +0200
+Subject: [PATCH 1/5] cogl/gl-framebuffer: Fix spurious trailing spaces
+
+Purely cosmetic fix, no functional change.
+
+Part-of: <https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/3047>
+---
+ cogl/cogl/driver/gl/cogl-gl-framebuffer-back.c | 12 ++++++------
+ cogl/cogl/driver/gl/cogl-gl-framebuffer-fbo.c | 12 ++++++------
+ 2 files changed, 12 insertions(+), 12 deletions(-)
+
+diff --git a/cogl/cogl/driver/gl/cogl-gl-framebuffer-back.c b/cogl/cogl/driver/gl/cogl-gl-framebuffer-back.c
+index d6609bb2074..8d76f1578bf 100644
+--- a/cogl/cogl/driver/gl/cogl-gl-framebuffer-back.c
++++ b/cogl/cogl/driver/gl/cogl-gl-framebuffer-back.c
+@@ -72,32 +72,32 @@ ensure_bits_initialized (CoglGlFramebufferBack *gl_framebuffer_back)
+ GLenum attachment, pname;
+ size_t offset;
+ } params[] = {
+- {
++ {
+ .attachment = GL_BACK_LEFT,
+ .pname = GL_FRAMEBUFFER_ATTACHMENT_RED_SIZE,
+ .offset = offsetof (CoglFramebufferBits, red),
+ },
+- {
++ {
+ .attachment = GL_BACK_LEFT,
+ .pname = GL_FRAMEBUFFER_ATTACHMENT_GREEN_SIZE,
+ .offset = offsetof (CoglFramebufferBits, green),
+ },
+- {
++ {
+ .attachment = GL_BACK_LEFT,
+ .pname = GL_FRAMEBUFFER_ATTACHMENT_BLUE_SIZE,
+ .offset = offsetof (CoglFramebufferBits, blue),
+ },
+- {
++ {
+ .attachment = GL_BACK_LEFT,
+ .pname = GL_FRAMEBUFFER_ATTACHMENT_ALPHA_SIZE,
+ .offset = offsetof (CoglFramebufferBits, alpha),
+ },
+- {
++ {
+ .attachment = GL_DEPTH,
+ .pname = GL_FRAMEBUFFER_ATTACHMENT_DEPTH_SIZE,
+ .offset = offsetof (CoglFramebufferBits, depth),
+ },
+- {
++ {
+ .attachment = GL_STENCIL,
+ .pname = GL_FRAMEBUFFER_ATTACHMENT_STENCIL_SIZE,
+ .offset = offsetof (CoglFramebufferBits, stencil),
+diff --git a/cogl/cogl/driver/gl/cogl-gl-framebuffer-fbo.c b/cogl/cogl/driver/gl/cogl-gl-framebuffer-fbo.c
+index c8db6a23a29..1ffc1d53509 100644
+--- a/cogl/cogl/driver/gl/cogl-gl-framebuffer-fbo.c
++++ b/cogl/cogl/driver/gl/cogl-gl-framebuffer-fbo.c
+@@ -82,32 +82,32 @@ ensure_bits_initialized (CoglGlFramebufferFbo *gl_framebuffer_fbo)
+ GLenum attachment, pname;
+ size_t offset;
+ } params[] = {
+- {
++ {
+ .attachment = GL_COLOR_ATTACHMENT0,
+ .pname = GL_FRAMEBUFFER_ATTACHMENT_RED_SIZE,
+ .offset = offsetof (CoglFramebufferBits, red),
+ },
+- {
++ {
+ .attachment = GL_COLOR_ATTACHMENT0,
+ .pname = GL_FRAMEBUFFER_ATTACHMENT_GREEN_SIZE,
+ .offset = offsetof (CoglFramebufferBits, green),
+ },
+- {
++ {
+ .attachment = GL_COLOR_ATTACHMENT0,
+ .pname = GL_FRAMEBUFFER_ATTACHMENT_BLUE_SIZE,
+ .offset = offsetof (CoglFramebufferBits, blue),
+ },
+- {
++ {
+ .attachment = GL_COLOR_ATTACHMENT0,
+ .pname = GL_FRAMEBUFFER_ATTACHMENT_ALPHA_SIZE,
+ .offset = offsetof (CoglFramebufferBits, alpha),
+ },
+- {
++ {
+ .attachment = GL_DEPTH_ATTACHMENT,
+ .pname = GL_FRAMEBUFFER_ATTACHMENT_DEPTH_SIZE,
+ .offset = offsetof (CoglFramebufferBits, depth),
+ },
+- {
++ {
+ .attachment = GL_STENCIL_ATTACHMENT,
+ .pname = GL_FRAMEBUFFER_ATTACHMENT_STENCIL_SIZE,
+ .offset = offsetof (CoglFramebufferBits, stencil),
+--
+GitLab
+
+
+From a2203df9f43b9e501a972d23b3d5584005c03ce6 Mon Sep 17 00:00:00 2001
+From: Olivier Fourdan <[email protected]>
+Date: Fri, 2 Jun 2023 11:54:58 +0200
+Subject: [PATCH 2/5] cogl/gl-framebuffer: Fix inverted test in
+ ensure_bits_initialized()
+
+Cogl's feature COGL_PRIVATE_FEATURE_QUERY_FRAMEBUFFER_BITS is required
+to use the GL_FRAMEBUFFER_ATTACHMENT_* queries.
+
+Unfortunately, the test for the availability of the private feature is
+actually inverted in ensure_bits_initialized() which causes that whole
+portion of code to be ignored, falling back to the glGetIntegerv()
+method which isn't supported in core profiles.
+
+As Mesa has recently started to be more strict about these, this causes
+the CI tests to fail in mutter.
+
+Part-of: <https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/3047>
+---
+ cogl/cogl/driver/gl/cogl-gl-framebuffer-fbo.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cogl/cogl/driver/gl/cogl-gl-framebuffer-fbo.c b/cogl/cogl/driver/gl/cogl-gl-framebuffer-fbo.c
+index 1ffc1d53509..75a8b0c1fe2 100644
+--- a/cogl/cogl/driver/gl/cogl-gl-framebuffer-fbo.c
++++ b/cogl/cogl/driver/gl/cogl-gl-framebuffer-fbo.c
+@@ -76,7 +76,7 @@ ensure_bits_initialized (CoglGlFramebufferFbo *gl_framebuffer_fbo)
+ COGL_FRAMEBUFFER_STATE_BIND);
+
+ #ifdef HAVE_COGL_GL
+- if (!_cogl_has_private_feature (ctx, COGL_PRIVATE_FEATURE_QUERY_FRAMEBUFFER_BITS))
++ if (_cogl_has_private_feature (ctx, COGL_PRIVATE_FEATURE_QUERY_FRAMEBUFFER_BITS))
+ {
+ const struct {
+ GLenum attachment, pname;
+--
+GitLab
+
+
+From fad240f437d6b11f664c9c09aecabe5f5e703eca Mon Sep 17 00:00:00 2001
+From: Olivier Fourdan <[email protected]>
+Date: Mon, 5 Jun 2023 10:31:38 +0200
+Subject: [PATCH 3/5] cogl/gl-framebuffer: Match testing features
+
+The function ensure_bits_initialized() in cogl-gl-framebuffer-fbo.c
+checks for COGL_PRIVATE_FEATURE_QUERY_FRAMEBUFFER_BITS whereas the same
+in cogl-gl-framebuffer-back.c simply checks for the driver being
+COGL_DRIVER_GL3.
+
+Change the later to use the COGL_PRIVATE_FEATURE_QUERY_FRAMEBUFFER_BITS
+flag as well.
+
+Part-of: <https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/3047>
+---
+ cogl/cogl/driver/gl/cogl-gl-framebuffer-back.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cogl/cogl/driver/gl/cogl-gl-framebuffer-back.c b/cogl/cogl/driver/gl/cogl-gl-framebuffer-back.c
+index 8d76f1578bf..f6a17e8f070 100644
+--- a/cogl/cogl/driver/gl/cogl-gl-framebuffer-back.c
++++ b/cogl/cogl/driver/gl/cogl-gl-framebuffer-back.c
+@@ -66,7 +66,7 @@ ensure_bits_initialized (CoglGlFramebufferBack *gl_framebuffer_back)
+ COGL_FRAMEBUFFER_STATE_BIND);
+
+ #ifdef HAVE_COGL_GL
+- if (ctx->driver == COGL_DRIVER_GL3)
++ if (_cogl_has_private_feature (ctx, COGL_PRIVATE_FEATURE_QUERY_FRAMEBUFFER_BITS))
+ {
+ const struct {
+ GLenum attachment, pname;
+--
+GitLab
+
+
+From c3af4c1b1571b05f67d48b90d9ea7313f3ca6003 Mon Sep 17 00:00:00 2001
+From: Olivier Fourdan <[email protected]>
+Date: Fri, 2 Jun 2023 14:27:29 +0200
+Subject: [PATCH 4/5] cogl/gl-framebuffer: Fail without QUERY_FRAMEBUFFER_BITS
+
+glGetIntegerv() with GL_RED_BITS/GL_GREEN_BITS/GL_BLUE_BITS/etc. is not
+supported with the GL core context, so there is no point in falling back
+to that without supporting COGL_PRIVATE_FEATURE_QUERY_FRAMEBUFFER_BITS,
+as this will cause an GL error.
+
+Part-of: <https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/3047>
+---
+ cogl/cogl/driver/gl/cogl-gl-framebuffer-back.c | 7 +------
+ cogl/cogl/driver/gl/cogl-gl-framebuffer-fbo.c | 7 +------
+ 2 files changed, 2 insertions(+), 12 deletions(-)
+
+diff --git a/cogl/cogl/driver/gl/cogl-gl-framebuffer-back.c b/cogl/cogl/driver/gl/cogl-gl-framebuffer-back.c
+index f6a17e8f070..0ccd2324077 100644
+--- a/cogl/cogl/driver/gl/cogl-gl-framebuffer-back.c
++++ b/cogl/cogl/driver/gl/cogl-gl-framebuffer-back.c
+@@ -119,12 +119,7 @@ ensure_bits_initialized (CoglGlFramebufferBack *gl_framebuffer_back)
+ else
+ #endif /* HAVE_COGL_GL */
+ {
+- GE (ctx, glGetIntegerv (GL_RED_BITS, &bits->red));
+- GE (ctx, glGetIntegerv (GL_GREEN_BITS, &bits->green));
+- GE (ctx, glGetIntegerv (GL_BLUE_BITS, &bits->blue));
+- GE (ctx, glGetIntegerv (GL_ALPHA_BITS, &bits->alpha));
+- GE (ctx, glGetIntegerv (GL_DEPTH_BITS, &bits->depth));
+- GE (ctx, glGetIntegerv (GL_STENCIL_BITS, &bits->stencil));
++ return FALSE;
+ }
+
+ COGL_NOTE (FRAMEBUFFER,
+diff --git a/cogl/cogl/driver/gl/cogl-gl-framebuffer-fbo.c b/cogl/cogl/driver/gl/cogl-gl-framebuffer-fbo.c
+index 75a8b0c1fe2..524196207f5 100644
+--- a/cogl/cogl/driver/gl/cogl-gl-framebuffer-fbo.c
++++ b/cogl/cogl/driver/gl/cogl-gl-framebuffer-fbo.c
+@@ -129,12 +129,7 @@ ensure_bits_initialized (CoglGlFramebufferFbo *gl_framebuffer_fbo)
+ else
+ #endif /* HAVE_COGL_GL */
+ {
+- GE (ctx, glGetIntegerv (GL_RED_BITS, &bits->red));
+- GE (ctx, glGetIntegerv (GL_GREEN_BITS, &bits->green));
+- GE (ctx, glGetIntegerv (GL_BLUE_BITS, &bits->blue));
+- GE (ctx, glGetIntegerv (GL_ALPHA_BITS, &bits->alpha));
+- GE (ctx, glGetIntegerv (GL_DEPTH_BITS, &bits->depth));
+- GE (ctx, glGetIntegerv (GL_STENCIL_BITS, &bits->stencil));
++ return FALSE;
+ }
+
+ if (!_cogl_has_private_feature (ctx, COGL_PRIVATE_FEATURE_ALPHA_TEXTURES) &&
+--
+GitLab
+
+
+From d65883e0d7d70987e3888b86222b109c35f5a7a2 Mon Sep 17 00:00:00 2001
+From: Olivier Fourdan <[email protected]>
+Date: Mon, 5 Jun 2023 10:38:41 +0200
+Subject: [PATCH 5/5] cogl/gl-framebuffer: Remove conditional on HAVE_COGL_GL
+
+By testing the features flag, we can get rid of the conditional build
+on HAVE_COGL_GL entirely.
+
+Part-of: <https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/3047>
+---
+ cogl/cogl/driver/gl/cogl-gl-framebuffer-back.c | 2 --
+ cogl/cogl/driver/gl/cogl-gl-framebuffer-fbo.c | 2 --
+ 2 files changed, 4 deletions(-)
+
+diff --git a/cogl/cogl/driver/gl/cogl-gl-framebuffer-back.c b/cogl/cogl/driver/gl/cogl-gl-framebuffer-back.c
+index 0ccd2324077..94154d48efb 100644
+--- a/cogl/cogl/driver/gl/cogl-gl-framebuffer-back.c
++++ b/cogl/cogl/driver/gl/cogl-gl-framebuffer-back.c
+@@ -65,7 +65,6 @@ ensure_bits_initialized (CoglGlFramebufferBack *gl_framebuffer_back)
+ framebuffer,
+ COGL_FRAMEBUFFER_STATE_BIND);
+
+-#ifdef HAVE_COGL_GL
+ if (_cogl_has_private_feature (ctx, COGL_PRIVATE_FEATURE_QUERY_FRAMEBUFFER_BITS))
+ {
+ const struct {
+@@ -117,7 +116,6 @@ ensure_bits_initialized (CoglGlFramebufferBack *gl_framebuffer_back)
+ }
+ }
+ else
+-#endif /* HAVE_COGL_GL */
+ {
+ return FALSE;
+ }
+diff --git a/cogl/cogl/driver/gl/cogl-gl-framebuffer-fbo.c b/cogl/cogl/driver/gl/cogl-gl-framebuffer-fbo.c
+index 524196207f5..3ea133d3143 100644
+--- a/cogl/cogl/driver/gl/cogl-gl-framebuffer-fbo.c
++++ b/cogl/cogl/driver/gl/cogl-gl-framebuffer-fbo.c
+@@ -75,7 +75,6 @@ ensure_bits_initialized (CoglGlFramebufferFbo *gl_framebuffer_fbo)
+ framebuffer,
+ COGL_FRAMEBUFFER_STATE_BIND);
+
+-#ifdef HAVE_COGL_GL
+ if (_cogl_has_private_feature (ctx, COGL_PRIVATE_FEATURE_QUERY_FRAMEBUFFER_BITS))
+ {
+ const struct {
+@@ -127,7 +126,6 @@ ensure_bits_initialized (CoglGlFramebufferFbo *gl_framebuffer_fbo)
+ }
+ }
+ else
+-#endif /* HAVE_COGL_GL */
+ {
+ return FALSE;
+ }
+--
+GitLab
+