summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/zig-use-baseline-cpu-by-default.patch
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2024-11-13 21:29:54 +0800
committerHilton Chain <hako@ultrarare.space>2024-12-31 10:54:05 +0800
commitcf74ecc94782bf3dc5588dc8988f39d34d3fa238 (patch)
tree8c5dfee4c2ce483b1e823d8249bda7c2396c84d3 /gnu/packages/patches/zig-use-baseline-cpu-by-default.patch
parentfa0e38cbaec13d84d34505f9e01d14345e653a08 (diff)
gnu: zig-0.9: Update patches.
* gnu/packages/patches/zig-0.9-fix-runpath.patch: New file. * gnu/packages/patches/zig-use-baseline-cpu-by-default.patch: Rename to... * gnu/packages/patches/zig-0.9-use-baseline-cpu-by-default.patch: ...this. * gnu/packages/patches/zig-use-system-paths.patch: Rename to... * gnu/packages/patches/zig-0.9-use-system-paths.patch: ...this and update. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/zig.scm (zig-0.9-glibc-abi-tool,zig-0.10-glibc-abi-tool): New variables. (zig-0.9)[source]: Use zig-source. Add patches. [arguments]<#:phases>: Generate and install abilists. [native-inputs]: Add zig-0.9-glibc-abi-tool. (zig-0.10)[source]<patches>: Adjust patch name. [native-inputs]: Replace zig-0.9-glibc-abi-tool with zig-0.10-glibc-abi-tool.
Diffstat (limited to 'gnu/packages/patches/zig-use-baseline-cpu-by-default.patch')
-rw-r--r--gnu/packages/patches/zig-use-baseline-cpu-by-default.patch36
1 files changed, 0 insertions, 36 deletions
diff --git a/gnu/packages/patches/zig-use-baseline-cpu-by-default.patch b/gnu/packages/patches/zig-use-baseline-cpu-by-default.patch
deleted file mode 100644
index be78d9c6c7..0000000000
--- a/gnu/packages/patches/zig-use-baseline-cpu-by-default.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 1dc188129950031243c5a0c80ec2562fab8ec549 Mon Sep 17 00:00:00 2001
-From: Ekaitz Zarraga <ekaitz@elenq.tech>
-Date: Sat, 18 Nov 2023 15:04:16 +0100
-Subject: [PATCH] Use `baseline` cpu by default.
-
-This helps Guix tune the package later. Tunning will only add
-`-Dcpu=whatever` which should override the standard behaviour.
-
-Zig by default uses `native`, which interferes with our build process.
-In our previous zig-build-system we chose to add `-Dcpu=baseline` flag
-in each `zig build` execution, but that doesn't allow us to tune the
-package later. Tunning is only designed to add extra flags in the
-command line call, and we already had one set for the baseline case.
-With this patch we set the standard behavior to `baseline` so we don't
-need to add the `-Dcpu=baseline` flag in the zig-build-system and we can
-tune with no issues.
----
- lib/std/zig/CrossTarget.zig | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/lib/std/zig/CrossTarget.zig b/lib/std/zig/CrossTarget.zig
-index 6c59a4a3a..f5ec065fe 100644
---- a/lib/std/zig/CrossTarget.zig
-+++ b/lib/std/zig/CrossTarget.zig
-@@ -12,7 +12,7 @@ const mem = std.mem;
- /// `null` means native.
- cpu_arch: ?Target.Cpu.Arch = null,
-
--cpu_model: CpuModel = CpuModel.determined_by_cpu_arch,
-+cpu_model: CpuModel = CpuModel.baseline,
-
- /// Sparse set of CPU features to add to the set from `cpu_model`.
- cpu_features_add: Target.Cpu.Feature.Set = Target.Cpu.Feature.Set.empty,
---
-2.41.0
-