summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/unzip-overflow-long-fsize.patch
diff options
context:
space:
mode:
authorMark H Weaver <[email protected]>2015-10-08 10:59:39 -0400
committerMark H Weaver <[email protected]>2015-10-08 10:59:39 -0400
commitb81378251c629615aff0d62ca686bb53a10367de (patch)
tree4c15f2be58d665cf0eed1e00c84f70764890c3b8 /gnu/packages/patches/unzip-overflow-long-fsize.patch
parent319fe79dd01e03c4ef61311c336bcd77e1133f02 (diff)
parentb5881775ac2db345bf5826d6351366346ff03275 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches/unzip-overflow-long-fsize.patch')
-rw-r--r--gnu/packages/patches/unzip-overflow-long-fsize.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/patches/unzip-overflow-long-fsize.patch b/gnu/packages/patches/unzip-overflow-long-fsize.patch
new file mode 100644
index 0000000000..76963480d5
--- /dev/null
+++ b/gnu/packages/patches/unzip-overflow-long-fsize.patch
@@ -0,0 +1,38 @@
+Copied from Fedora.
+
+http://pkgs.fedoraproject.org/cgit/unzip.git/plain/unzip-6.0-overflow-long-fsize.patch?id=d18f821e
+
+diff --git a/list.c b/list.c
+index f7359c3..4c3d703 100644
+--- a/list.c
++++ b/list.c
+@@ -97,7 +97,7 @@ int list_files(__G) /* return PK-type error code */
+ {
+ int do_this_file=FALSE, cfactor, error, error_in_archive=PK_COOL;
+ #ifndef WINDLL
+- char sgn, cfactorstr[10];
++ char sgn, cfactorstr[13];
+ int longhdr=(uO.vflag>1);
+ #endif
+ int date_format;
+@@ -339,7 +339,19 @@ int list_files(__G) /* return PK-type error code */
+ G.crec.compression_method == ENHDEFLATED) {
+ methbuf[5] = dtype[(G.crec.general_purpose_bit_flag>>1) & 3];
+ } else if (methnum >= NUM_METHODS) {
+- sprintf(&methbuf[4], "%03u", G.crec.compression_method);
++ /* 2013-02-26 SMS.
++ * http://sourceforge.net/tracker/?func=detail
++ * &aid=2861648&group_id=118012&atid=679786
++ * Unexpectedly large compression methods overflow
++ * &methbuf[]. Use the old, three-digit decimal format
++ * for values which fit. Otherwise, sacrifice the
++ * colon, and use four-digit hexadecimal.
++ */
++ if (G.crec.compression_method <= 999) {
++ sprintf( &methbuf[ 4], "%03u", G.crec.compression_method);
++ } else {
++ sprintf( &methbuf[ 3], "%04X", G.crec.compression_method);
++ }
+ }
+
+ #if 0 /* GRR/Euro: add this? */