summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/tcsh-fix-out-of-bounds-read.patch
diff options
context:
space:
mode:
authorMarius Bakke <[email protected]>2019-11-30 04:37:57 +0100
committerMarius Bakke <[email protected]>2019-12-05 17:59:10 +0100
commitd098aa3e67b934f61758430c4740cd86d1ff234d (patch)
tree74125cc41f36359f393b10b7d485043769001190 /gnu/packages/patches/tcsh-fix-out-of-bounds-read.patch
parenta80cfbdcb96b71285aac01584aca4f9af3c6b3d1 (diff)
gnu: tcsh: Update to 6.22.02.
* gnu/packages/patches/tcsh-fix-autotest.patch: Adjust for 6.22.02. * gnu/packages/patches/tcsh-fix-out-of-bounds-read.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/shells.scm (tcsh): Update to 6.22.02. [source](patches): Remove obsolete patch.
Diffstat (limited to 'gnu/packages/patches/tcsh-fix-out-of-bounds-read.patch')
-rw-r--r--gnu/packages/patches/tcsh-fix-out-of-bounds-read.patch31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/patches/tcsh-fix-out-of-bounds-read.patch b/gnu/packages/patches/tcsh-fix-out-of-bounds-read.patch
deleted file mode 100644
index 48c294f78e..0000000000
--- a/gnu/packages/patches/tcsh-fix-out-of-bounds-read.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Fix out-of-bounds read in c_substitute():
-
-http://seclists.org/oss-sec/2016/q4/612
-
-Patch copied from upstream source repository:
-
-https://github.com/tcsh-org/tcsh/commit/6a542dc4fb2ba26518a47e9b3a9bcd6a91b94596
-
-From 6a542dc4fb2ba26518a47e9b3a9bcd6a91b94596 Mon Sep 17 00:00:00 2001
-From: christos <christos>
-Date: Fri, 2 Dec 2016 16:59:28 +0000
-Subject: [PATCH] Fix out of bounds read (Brooks Davis) (reproduce by starting
- tcsh and hitting tab at the prompt)
-
----
- ed.chared.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/ed.chared.c b/ed.chared.c
-index 1277e53..310393e 100644
---- ed.chared.c
-+++ ed.chared.c
-@@ -750,7 +750,7 @@ c_substitute(void)
- /*
- * If we found a history character, go expand it.
- */
-- if (HIST != '\0' && *p == HIST)
-+ if (p >= InputBuf && HIST != '\0' && *p == HIST)
- nr_exp = c_excl(p);
- else
- nr_exp = 0;