summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/rust-1.70-fix-rustix-build.patch
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2023-10-21 20:34:46 +0300
committerEfraim Flashner <[email protected]>2023-10-21 20:34:46 +0300
commite6af40d7b46b5c9e397a38c62c885fb42ccd9d26 (patch)
treee4b264c393e39c475e2476d152f747a84d5aa4d0 /gnu/packages/patches/rust-1.70-fix-rustix-build.patch
parent760a210b747a93e7b6256509d1375575b9a1ec2f (diff)
parent003dc790fdccb2e762edbe09abbc1b6f24f18de0 (diff)
Merge remote-tracking branch 'origin/rust-team'
Diffstat (limited to 'gnu/packages/patches/rust-1.70-fix-rustix-build.patch')
-rw-r--r--gnu/packages/patches/rust-1.70-fix-rustix-build.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/patches/rust-1.70-fix-rustix-build.patch b/gnu/packages/patches/rust-1.70-fix-rustix-build.patch
new file mode 100644
index 0000000000..d72a8fb07a
--- /dev/null
+++ b/gnu/packages/patches/rust-1.70-fix-rustix-build.patch
@@ -0,0 +1,21 @@
+@@ -0,0 +1,20 @@
+--- a/vendor/fd-lock/Cargo.toml 2023-05-31 14:44:48.000000000 -0700
++++ b/vendor/fd-lock/Cargo.toml 2023-07-14 21:19:34.637702319 -0700
+@@ -45,7 +45,7 @@
+
+ [target."cfg(unix)".dependencies.rustix]
+ version = "0.37.0"
+-features = ["fs"]
++features = ["fs", "cc"]
+
+ [target."cfg(windows)".dependencies.windows-sys]
+ version = "0.45.0"
+--- a/src/bootstrap/Cargo.lock 2023-07-11 20:32:40.000000000 -0700
++++ b/src/bootstrap/Cargo.lock 2023-07-14 22:41:53.269284713 -0700
+@@ -618,6 +618,7 @@
+ dependencies = [
+ "bitflags",
++ "cc",
+ "errno",
+ "io-lifetimes",
+ "libc",