summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/qemu-disable-migration-test.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <[email protected]>2025-02-23 22:26:48 +0900
committerMaxim Cournoyer <[email protected]>2025-03-05 14:23:42 +0900
commit4a1ea5d0dae3f1c26e0eb67811b5f1f331541fbc (patch)
tree4cc6b3afcf7f8bc81227e345ed46fd9792d68d74 /gnu/packages/patches/qemu-disable-migration-test.patch
parent84a351b3de4bd36e54b58da773bfb46d5b70c522 (diff)
gnu: qemu: Update to 9.1.3.
* gnu/packages/virtualization.scm (qemu): Update to 9.1.3. [source] <patches>: Add qemu-disable-migration-test.patch. [arguments] <phases>: Adjust install-user-static phase. [native-inputs]: Add python-tomli. (qemu-patch): Delete procedure. * gnu/packages/patches/qemu-disable-bios-tables-test.patch: Rebase. * gnu/packages/patches/qemu-fix-agent-paths.patch: Likewise. * gnu/packages/patches/qemu-disable-aarch64-migration-test.patch: Delete file. * gnu/packages/patches/qemu-disable-migration-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. Change-Id: I573070a297ffc9ca096c52e2fa18f839ad89a24e
Diffstat (limited to 'gnu/packages/patches/qemu-disable-migration-test.patch')
-rw-r--r--gnu/packages/patches/qemu-disable-migration-test.patch57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/patches/qemu-disable-migration-test.patch b/gnu/packages/patches/qemu-disable-migration-test.patch
new file mode 100644
index 0000000000..2a30d26f55
--- /dev/null
+++ b/gnu/packages/patches/qemu-disable-migration-test.patch
@@ -0,0 +1,57 @@
+diff --git a/tests/qtest/meson.build b/tests/qtest/meson.build
+index e3c33a86b5..a3bbf9c841 100644
+--- a/tests/qtest/meson.build
++++ b/tests/qtest/meson.build
+@@ -2,7 +2,6 @@ slow_qtests = {
+ 'aspeed_smc-test': 360,
+ 'cdrom-test' : 610,
+ 'device-introspect-test' : 720,
+- 'migration-test' : 480,
+ 'npcm7xx_pwm-test': 300,
+ 'npcm7xx_watchdog_timer-test': 120,
+ 'qom-test' : 900,
+@@ -100,7 +99,6 @@ qtests_i386 = \
+ 'cpu-plug-test',
+ 'q35-test',
+ 'vmgenid-test',
+- 'migration-test',
+ 'test-x86-cpuid-compat',
+ 'numa-test'
+ ]
+@@ -173,7 +171,7 @@ qtests_ppc64 = \
+ (slirp.found() ? ['pxe-test'] : []) + \
+ (config_all_devices.has_key('CONFIG_USB_UHCI') ? ['usb-hcd-uhci-test'] : []) + \
+ (config_all_devices.has_key('CONFIG_USB_XHCI_NEC') ? ['usb-hcd-xhci-test'] : []) + \
+- qtests_pci + ['migration-test', 'numa-test', 'cpu-plug-test', 'drive_del-test']
++ qtests_pci + ['numa-test', 'cpu-plug-test', 'drive_del-test']
+
+ qtests_sh4 = (config_all_devices.has_key('CONFIG_ISA_TESTDEV') ? ['endianness-test'] : [])
+ qtests_sh4eb = (config_all_devices.has_key('CONFIG_ISA_TESTDEV') ? ['endianness-test'] : [])
+@@ -240,8 +238,7 @@ qtests_aarch64 = \
+ config_all_devices.has_key('CONFIG_TPM_TIS_I2C') ? ['tpm-tis-i2c-test'] : []) + \
+ ['arm-cpu-features',
+ 'numa-test',
+- 'boot-serial-test',
+- 'migration-test']
++ 'boot-serial-test']
+
+ qtests_s390x = \
+ qtests_filter + \
+@@ -249,8 +246,7 @@ qtests_s390x = \
+ 'drive_del-test',
+ 'device-plug-test',
+ 'virtio-ccw-test',
+- 'cpu-plug-test',
+- 'migration-test']
++ 'cpu-plug-test']
+
+ qtests_riscv32 = \
+ (config_all_devices.has_key('CONFIG_SIFIVE_E_AON') ? ['sifive-e-aon-watchdog-test'] : [])
+@@ -324,7 +320,6 @@ qtests = {
+ 'dbus-vmstate-test': files('migration-helpers.c') + dbus_vmstate1,
+ 'erst-test': files('erst-test.c'),
+ 'ivshmem-test': [rt, '../../contrib/ivshmem-server/ivshmem-server.c'],
+- 'migration-test': migration_files,
+ 'pxe-test': files('boot-sector.c'),
+ 'qos-test': [chardev, io, qos_test_ss.apply({}).sources()],
+ 'tpm-crb-swtpm-test': [io, tpmemu_files],