summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/openjdk-9-hotspot-stack-size.patch
diff options
context:
space:
mode:
authorMarius Bakke <[email protected]>2022-09-13 00:57:31 +0200
committerMarius Bakke <[email protected]>2022-09-13 14:53:08 +0200
commit389b5b5359e82be5e0417fd3505661b1800fca40 (patch)
tree60d06dbbded034aa4519ef44b0e0b689efe22cdc /gnu/packages/patches/openjdk-9-hotspot-stack-size.patch
parent321e866b1cea4916e3568efb84a248e5bb91200a (diff)
gnu: OpenJDK@9: Fix build with newer toolchain.
* gnu/packages/java.scm (openjdk9)[source](patches): New field. * gnu/packages/patches/openjdk-9-hotspot-pointer-comparison.patch, gnu/packages/patches/openjdk-9-hotspot-stack-size.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/patches/openjdk-9-hotspot-stack-size.patch')
-rw-r--r--gnu/packages/patches/openjdk-9-hotspot-stack-size.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/patches/openjdk-9-hotspot-stack-size.patch b/gnu/packages/patches/openjdk-9-hotspot-stack-size.patch
new file mode 100644
index 0000000000..27af0ab6c2
--- /dev/null
+++ b/gnu/packages/patches/openjdk-9-hotspot-stack-size.patch
@@ -0,0 +1,28 @@
+Dynamically allocate the stack since SIGSTKSZ is not constant since glibc 2.34.
+
+Backported from:
+
+ https://github.com/openjdk/jdk17u/commit/bb7c412e259893091210267252faf3c0a1be0969
+
+diff --git a/hotspot/test/runtime/StackGuardPages/exeinvoke.c b/hotspot/test/runtime/StackGuardPages/exeinvoke.c
+--- a/hotspot/test/runtime/StackGuardPages/exeinvoke.c
++++ b/hotspot/test/runtime/StackGuardPages/exeinvoke.c
+@@ -67,8 +67,17 @@ static void handler(int sig, siginfo_t *si, void *unused) {
+ longjmp(context, 1);
+ }
+
++static char* altstack = NULL;
++
+ void set_signal_handler() {
+- static char altstack[SIGSTKSZ];
++ if (altstack == NULL) {
++ // Dynamically allocated in case SIGSTKSZ is not constant
++ altstack = malloc(SIGSTKSZ);
++ if (altstack == NULL) {
++ fprintf(stderr, "Test ERROR. Unable to malloc altstack space\n");
++ exit(7);
++ }
++ }
+
+ stack_t ss = {
+ .ss_size = SIGSTKSZ,