summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/mercurial-hg-extension-path.patch
diff options
context:
space:
mode:
authorArne Babenhauserheide <[email protected]>2024-04-13 14:58:08 +0200
committerGreg Hogan <[email protected]>2025-03-10 17:06:26 +0000
commit78f8266056c305e115b310fa6f06f72d42967eb0 (patch)
tree0d3d6333b0cebb85d4a40a0ab847bb64935e5ab7 /gnu/packages/patches/mercurial-hg-extension-path.patch
parent519fc51b6ecfe9ac9f2fa2f4ae052ab1984eed22 (diff)
gnu: mercurial: Update to 6.7.2.
* gnu/packages/version-control.scm (mercurial): Update to 6.7.2. [source]<origin>(patches): Remove mercurial-openssl-compat.patch. * gnu/packages/patches/mercurial-hg-extension-path.patch: adapt for mercurial 6.7.2. * gnu/packages/patches/mercurial-openssl-compat.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Unregister it. Change-Id: I1e22d7f38e264576bfa3adef7004fef582a1137e Signed-off-by: Greg Hogan <[email protected]>
Diffstat (limited to 'gnu/packages/patches/mercurial-hg-extension-path.patch')
-rw-r--r--gnu/packages/patches/mercurial-hg-extension-path.patch14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/patches/mercurial-hg-extension-path.patch b/gnu/packages/patches/mercurial-hg-extension-path.patch
index d1073dd01c..8b9d185a89 100644
--- a/gnu/packages/patches/mercurial-hg-extension-path.patch
+++ b/gnu/packages/patches/mercurial-hg-extension-path.patch
@@ -7,15 +7,7 @@ will get this into Mercurial proper.
diff --git a/mercurial/extensions.py b/mercurial/extensions.py
--- a/mercurial/extensions.py
+++ b/mercurial/extensions.py
-@@ -13,6 +13,7 @@
- import imp
- import inspect
- import os
-+import sys
-
- from .i18n import (
- _,
-@@ -108,6 +109,11 @@
+@@ -103,6 +103,11 @@
def _importh(name):
"""import and return the <name> module"""
@@ -24,6 +16,6 @@ diff --git a/mercurial/extensions.py b/mercurial/extensions.py
+ if extension_path is not None:
+ for path in extension_path:
+ sys.path.append(path)
- mod = __import__(pycompat.sysstr(name))
- components = name.split(b'.')
+ mod = __import__(name)
+ components = name.split('.')
for comp in components[1:]: