summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libxml2-bug-751631.patch
diff options
context:
space:
mode:
authorMark H Weaver <[email protected]>2015-12-03 17:18:24 -0500
committerMark H Weaver <[email protected]>2015-12-07 09:54:01 -0500
commit821060f3f66a45acd8b5726e8f7ecdd879754341 (patch)
tree977a3a46b044806118250135a9ca48d4bda1a163 /gnu/packages/patches/libxml2-bug-751631.patch
parent86c8f1daf8ed10f13f2b1e973a28845629b8ce47 (diff)
gnu: libxml2: Update to 2.9.3.
* gnu/packages/patches/libxml2-CVE-2015-1819.patch, gnu/packages/patches/libxml2-CVE-2015-7941-pt1.patch, gnu/packages/patches/libxml2-CVE-2015-7941-pt2.patch, gnu/packages/patches/libxml2-CVE-2015-7942-pt1.patch, gnu/packages/patches/libxml2-CVE-2015-7942-pt2.patch, gnu/packages/patches/libxml2-CVE-2015-8035.patch, gnu/packages/patches/libxml2-bug-737840.patch, gnu/packages/patches/libxml2-bug-738805.patch, gnu/packages/patches/libxml2-bug-746048.patch, gnu/packages/patches/libxml2-bug-747437.patch, gnu/packages/patches/libxml2-bug-751603.patch, gnu/packages/patches/libxml2-bug-751631.patch, gnu/packages/patches/libxml2-bug-754946.patch, gnu/packages/patches/libxml2-bug-754947.patch, gnu/packages/patches/libxml2-bug-755857.patch, gnu/packages/patches/libxml2-fix-catalog-corruption.patch, gnu/packages/patches/libxml2-id-attrs-in-xmlSetTreeDoc.patch, gnu/packages/patches/libxml2-node-sort-order-pt1.patch, gnu/packages/patches/libxml2-node-sort-order-pt2.patch: Delete files. * gnu-system.am (dist_patch_DATA): Remove them. * gnu/packages/xml.scm (libxml2): Update to 2.9.3. Remove patches.
Diffstat (limited to 'gnu/packages/patches/libxml2-bug-751631.patch')
-rw-r--r--gnu/packages/patches/libxml2-bug-751631.patch35
1 files changed, 0 insertions, 35 deletions
diff --git a/gnu/packages/patches/libxml2-bug-751631.patch b/gnu/packages/patches/libxml2-bug-751631.patch
deleted file mode 100644
index 33344e35d2..0000000000
--- a/gnu/packages/patches/libxml2-bug-751631.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 709a952110e98621c9b78c4f26462a9d8333102e Mon Sep 17 00:00:00 2001
-From: Daniel Veillard <[email protected]>
-Date: Mon, 29 Jun 2015 16:10:26 +0800
-Subject: [PATCH] Fail parsing early on if encoding conversion failed
-
-For https://bugzilla.gnome.org/show_bug.cgi?id=751631
-
-If we fail conversing the current input stream while
-processing the encoding declaration of the XMLDecl
-then it's safer to just abort there and not try to
-report further errors.
----
- parser.c | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/parser.c b/parser.c
-index a3a9568..0edd53b 100644
---- a/parser.c
-+++ b/parser.c
-@@ -10471,7 +10471,11 @@ xmlParseEncodingDecl(xmlParserCtxtPtr ctxt) {
-
- handler = xmlFindCharEncodingHandler((const char *) encoding);
- if (handler != NULL) {
-- xmlSwitchToEncoding(ctxt, handler);
-+ if (xmlSwitchToEncoding(ctxt, handler) < 0) {
-+ /* failed to convert */
-+ ctxt->errNo = XML_ERR_UNSUPPORTED_ENCODING;
-+ return(NULL);
-+ }
- } else {
- xmlFatalErrMsgStr(ctxt, XML_ERR_UNSUPPORTED_ENCODING,
- "Unsupported encoding %s\n", encoding);
---
-2.6.3
-