summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/kodi-increase-test-timeout.patch
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2022-12-31 00:55:43 +0100
committerRicardo Wurmus <[email protected]>2022-12-31 00:55:43 +0100
commitdbd9305a5682b1c5cd0b2a516b09f1f3af47209d (patch)
tree45522c2fb73d2eb6a940d65d6076bb52be61f00e /gnu/packages/patches/kodi-increase-test-timeout.patch
parent01a2b3cce618b3b3ecb8431bba54747fe2b3377f (diff)
gnu: kodi: Update to 19.5.
* gnu/packages/kodi.scm (kodi): Update to 19.5. [source]: Remove obsolete patches; delete bundled jars. [arguments]: Update configure flags; adjust build phase 'patch-stuff to use Groovy from Guix; adjust file names; remove obsolete substitutions; disable TestCPUInfo.GetCPUFrequency test; remove trailing #T from build phases. [native-inputs]: Drop input labels; add googletest, groovy, openjdk9, and java-commons-lang; remove icedtea. [inputs]: Add spdlog-for-kodi; replace fmt-7 with fmt-6 (for spdlog). (kodi/wayland)[arguments]: Adjust configure flags. [inputs]: Use modify-inputs. * gnu/local.mk (dist_patch_DATA): Remove obsolete patches. * gnu/packages/patches/kodi-set-libcurl-ssl-parameters.patch: Adjust. * gnu/packages/patches/kodi-increase-test-timeout.patch: Remove file. * gnu/packages/patches/kodi-skip-test-449.patch: Remove file.
Diffstat (limited to 'gnu/packages/patches/kodi-increase-test-timeout.patch')
-rw-r--r--gnu/packages/patches/kodi-increase-test-timeout.patch18
1 files changed, 0 insertions, 18 deletions
diff --git a/gnu/packages/patches/kodi-increase-test-timeout.patch b/gnu/packages/patches/kodi-increase-test-timeout.patch
deleted file mode 100644
index 8fb149ff9d..0000000000
--- a/gnu/packages/patches/kodi-increase-test-timeout.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Increase thread timeout to reduce flakiness.
-
-Taken from upstream:
-https://github.com/xbmc/xbmc/commit/574b0182d8b641fd24029f372ebdcccc897123e2
-
-diff --git a/xbmc/threads/test/TestEvent.cpp b/xbmc/threads/test/TestEvent.cpp
-index 42fb8c2fc609..40e644c0ed3c 100644
---- a/xbmc/threads/test/TestEvent.cpp
-+++ b/xbmc/threads/test/TestEvent.cpp
-@@ -484,7 +484,7 @@ TEST(TestEvent, GroupTimedWait)
- EXPECT_TRUE(w3.result == NULL);
-
- // this should end given the wait is for only 50 millis
-- EXPECT_TRUE(waitThread3.timed_join(MILLIS(100)));
-+ EXPECT_TRUE(waitThread3.timed_join(MILLIS(200)));
-
- EXPECT_TRUE(!w3.waiting);
- EXPECT_TRUE(w3.result == NULL);