summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gcc-10-tree-sra-union-handling.patch
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2025-03-02 15:07:37 +0200
committerEfraim Flashner <[email protected]>2025-03-02 16:43:41 +0200
commit17b7b1a5cf1339bc5455c1576bb6431e9b3b23ff (patch)
tree93d23ed9605e55a00778d61dfd0831f2da02b230 /gnu/packages/patches/gcc-10-tree-sra-union-handling.patch
parent61ca5bdbce55c38615b6f98a1835fa64b5220a7b (diff)
gnu: Remove unreferenced patches.
* gnu/packages/patches/cyrus-sasl-ac-try-run-fix.patch, gnu/packages/patches/gcc-10-tree-sra-union-handling.patch, gnu/packages/patches/gegl-compatibility-old-librsvg.patch: Remove files. Change-Id: Ic1e502ef44ac3e8645d813e50018a0ca2c8be706
Diffstat (limited to 'gnu/packages/patches/gcc-10-tree-sra-union-handling.patch')
-rw-r--r--gnu/packages/patches/gcc-10-tree-sra-union-handling.patch33
1 files changed, 0 insertions, 33 deletions
diff --git a/gnu/packages/patches/gcc-10-tree-sra-union-handling.patch b/gnu/packages/patches/gcc-10-tree-sra-union-handling.patch
deleted file mode 100644
index aae5fc9f72..0000000000
--- a/gnu/packages/patches/gcc-10-tree-sra-union-handling.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Fix a regression in GCC 10/11/12 where some union structures
-could get miscompiled when optimizations are enabled:
-
- https://gcc.gnu.org/bugzilla/show_bug.cgi?id=105860
-
-Taken from upstream:
-
- https://gcc.gnu.org/g:16afe2e2862f3dd93c711d7f8d436dee23c6c34d
-
-diff --git a/gcc/tree-sra.c b/gcc/tree-sra.c
-index 09d951a261b..420329f63f6 100644
---- a/gcc/tree-sra.c
-+++ b/gcc/tree-sra.c
-@@ -1647,7 +1647,18 @@ build_ref_for_offset (location_t loc, tree base, poly_int64 offset,
- static tree
- build_reconstructed_reference (location_t, tree base, struct access *model)
- {
-- tree expr = model->expr, prev_expr = NULL;
-+ tree expr = model->expr;
-+ /* We have to make sure to start just below the outermost union. */
-+ tree start_expr = expr;
-+ while (handled_component_p (expr))
-+ {
-+ if (TREE_CODE (TREE_TYPE (TREE_OPERAND (expr, 0))) == UNION_TYPE)
-+ start_expr = expr;
-+ expr = TREE_OPERAND (expr, 0);
-+ }
-+
-+ expr = start_expr;
-+ tree prev_expr = NULL_TREE;
- while (!types_compatible_p (TREE_TYPE (expr), TREE_TYPE (base)))
- {
- if (!handled_component_p (expr))