summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/desmume-gcc7-fixes.patch
diff options
context:
space:
mode:
authorHendursaga <[email protected]>2023-09-19 16:42:15 -0400
committerLiliana Marie Prikler <[email protected]>2023-10-01 08:14:55 +0200
commitb14f44710652c90e4a96ece966644021c877c0e9 (patch)
tree0e0b8b10d8de19ab1ae40eef6ec45115035c0e9b /gnu/packages/patches/desmume-gcc7-fixes.patch
parent8027ee43373638e0773fec3532c1a13d3da95b6a (diff)
gnu: desmume: Update to 0.9.13.
* gnu/packages/emulators.scm (desmume): Update to 0.9.13. [source]: Switch to git-fetch. Remove patches. [build-system]: Switch to meson-build-system. [arguments]<#:configure-flags>: Replace “--enable-openal” with “-Dopenal=true”. Remove “--enable-wifi”. Add “-Dfrontend-cli=true”, “-Dfrontend-gtk=true”, and “-Dgdb-stub=true”. <#:phases>: Add ‘chdir’. [native-inputs]: Add glib:bin and gettext-minimal. [inputs]: Replace sdl with sdl2 and gtk+-2 with gtk+. Remove glu. Add agg, alsa-lib, libpcap, openal, and soundtouch. [home-page]: Use HTTPS. * gnu/packages/patches/desmume-gcc6-fixes.patch: Removed file. * gnu/packages/patches/desmume-gcc7-fixes.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. Signed-off-by: Liliana Marie Prikler <[email protected]>
Diffstat (limited to 'gnu/packages/patches/desmume-gcc7-fixes.patch')
-rw-r--r--gnu/packages/patches/desmume-gcc7-fixes.patch18
1 files changed, 0 insertions, 18 deletions
diff --git a/gnu/packages/patches/desmume-gcc7-fixes.patch b/gnu/packages/patches/desmume-gcc7-fixes.patch
deleted file mode 100644
index a4934ff6e6..0000000000
--- a/gnu/packages/patches/desmume-gcc7-fixes.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-From e1f7039f1b06add4fb75b2f8774000b8f05574af Mon Sep 17 00:00:00 2001
-From: rogerman <[email protected]>
-Date: Mon, 17 Aug 2015 21:15:04 +0000
-Subject: Fix bug with libfat string handling.
-
-diff --git a/src/utils/libfat/directory.cpp b/src/utils/libfat/directory.cpp
-index 765d7ae5..b6d7f01f 100644
---- a/src/utils/libfat/directory.cpp
-+++ b/src/utils/libfat/directory.cpp
-@@ -139,7 +139,7 @@ static size_t _FAT_directory_mbstoucs2 (ucs2_t* dst, const char* src, size_t len
- int bytes;
- size_t count = 0;
-
-- while (count < len-1 && src != '\0') {
-+ while (count < len-1 && *src != '\0') {
- bytes = mbrtowc (&tempChar, src, MB_CUR_MAX, &ps);
- if (bytes > 0) {
- *dst = (ucs2_t)tempChar;