summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/bitlbee-fix-tests.patch
diff options
context:
space:
mode:
authorMark H Weaver <[email protected]>2014-03-06 00:07:07 -0500
committerMark H Weaver <[email protected]>2014-03-06 10:23:45 -0500
commit8b3099cf03b2d1ebcd233b4a35d132cd73b5728d (patch)
treeb7b0936db24f4d7399948f716ffa053ba7259600 /gnu/packages/patches/bitlbee-fix-tests.patch
parent7c706558f564e878415a14d32286c31c5ef370fb (diff)
gnu: Add bitlbee.
* gnu/packages/messaging.scm (bitlbee): New variable. * gnu/packages/patches/bitlbee-fix-tests.patch: New file. * gnu/packages/patches/bitlbee-memset-fix.patch: New file. * gnu-system.am (dist_patch_DATA): Add patches.
Diffstat (limited to 'gnu/packages/patches/bitlbee-fix-tests.patch')
-rw-r--r--gnu/packages/patches/bitlbee-fix-tests.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/patches/bitlbee-fix-tests.patch b/gnu/packages/patches/bitlbee-fix-tests.patch
new file mode 100644
index 0000000000..52bb6c605d
--- /dev/null
+++ b/gnu/packages/patches/bitlbee-fix-tests.patch
@@ -0,0 +1,33 @@
+Pass the correct number of arguments to 'nick_strip' and 'nick_ok' in tests.
+
+Patch by Mark H Weaver <[email protected]>.
+
+--- bitlbee/tests/check_nick.c.orig 2013-11-27 17:54:54.000000000 -0500
++++ bitlbee/tests/check_nick.c 2014-03-05 23:41:45.761230468 -0500
+@@ -30,7 +30,7 @@ START_TEST(test_nick_strip)
+ for (i = 0; get[i]; i++) {
+ char copy[60];
+ strcpy(copy, get[i]);
+- nick_strip(copy);
++ nick_strip(NULL, copy);
+ fail_unless (strcmp(copy, expected[i]) == 0,
+ "(%d) nick_strip broken: %s -> %s (expected: %s)",
+ i, get[i], copy, expected[i]);
+@@ -45,7 +45,7 @@ START_TEST(test_nick_ok_ok)
+ int i;
+
+ for (i = 0; nicks[i]; i++) {
+- fail_unless (nick_ok(nicks[i]) == 1,
++ fail_unless (nick_ok(NULL, nicks[i]) == 1,
+ "nick_ok() failed: %s", nicks[i]);
+ }
+ }
+@@ -58,7 +58,7 @@ START_TEST(test_nick_ok_notok)
+ int i;
+
+ for (i = 0; nicks[i]; i++) {
+- fail_unless (nick_ok(nicks[i]) == 0,
++ fail_unless (nick_ok(NULL, nicks[i]) == 0,
+ "nick_ok() succeeded for invalid: %s", nicks[i]);
+ }
+ }