summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/aws-sdk-cpp-disable-werror.patch
diff options
context:
space:
mode:
authorGreg Hogan <[email protected]>2021-03-18 17:53:12 +0000
committerLudovic Courtès <[email protected]>2021-10-16 00:01:59 +0200
commitef0c65969b797a22572446df55b40efcff4d4037 (patch)
treee26787a37bc23e6a1dd62becc06f67db33eb3fff /gnu/packages/patches/aws-sdk-cpp-disable-werror.patch
parent5ed42eb9a01e63c25d6c0836b6a1b15e8d5fbd74 (diff)
gnu: aws-sdk-cpp: Update to 1.9.92.
* gnu/packages/patches/aws-sdk-cpp-cmake-prefix.patch, gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch, gnu/packages/patches/aws-sdk-cpp-disable-werror.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/cpp.scm (aws-sdk-cpp): Update to 1.9.92. [source]: Use patches. [inputs, propagated-inputs]: Update AWS dependencies to Common Runtime. Signed-off-by: Ludovic Courtès <[email protected]>
Diffstat (limited to 'gnu/packages/patches/aws-sdk-cpp-disable-werror.patch')
-rw-r--r--gnu/packages/patches/aws-sdk-cpp-disable-werror.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/patches/aws-sdk-cpp-disable-werror.patch b/gnu/packages/patches/aws-sdk-cpp-disable-werror.patch
new file mode 100644
index 0000000000..249c299239
--- /dev/null
+++ b/gnu/packages/patches/aws-sdk-cpp-disable-werror.patch
@@ -0,0 +1,11 @@
+--- a/cmake/compiler_settings.cmake
++++ b/cmake/compiler_settings.cmake
+@@ -53,7 +53,7 @@ macro(set_gcc_flags)
+ endmacro()
+
+ macro(set_gcc_warnings)
+- list(APPEND AWS_COMPILER_WARNINGS "-Wall" "-Werror" "-pedantic" "-Wextra")
++ list(APPEND AWS_COMPILER_WARNINGS "-Wall" "-pedantic" "-Wextra")
+ if(COMPILER_CLANG)
+ if(PLATFORM_ANDROID)
+ # when using clang with libc and API lower than 21 we need to include Android support headers and ignore the gnu-include-next warning.