summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-10-18 18:08:57 +0000
committerLudovic Courtès <ludo@gnu.org>2021-11-16 16:59:51 +0100
commitc769b8c2b5bf97cf9aaaa9b151012763355b1f66 (patch)
tree36a5cf05cdedc471238d481278d5703dabe5e615 /gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch
parent37db6db2841e7e5c9be54dd198964046a53d2c71 (diff)
gnu: aws-sdk-cpp: Update to 1.9.136.
* gnu/packages/cpp.scm (aws-sdk-cpp): Update to 1.9.136. [arguments]: Fix CMAKE_PREFIX_PATH. [source]: Remove patches. * gnu/packages/patches/aws-sdk-cpp-cmake-prefix.patch, gnu/packages/patches/aws-sdk-cpp-disable-network-tests.patch, gnu/packages/patches/aws-sdk-cpp-disable-werror.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch')
-rw-r--r--gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch44
1 files changed, 0 insertions, 44 deletions
diff --git a/gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch b/gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch
deleted file mode 100644
index 3b582d9628..0000000000
--- a/gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- a/aws-cpp-sdk-core-tests/http/HttpClientTest.cpp
-+++ b/aws-cpp-sdk-core-tests/http/HttpClientTest.cpp
-@@ -92,12 +92,12 @@ TEST(HttpClientTest, TestRandomURLWithNoProxy)
- makeRandomHttpRequest(httpClient, false);
- }
-
--TEST(HttpClientTest, TestRandomURLWithProxy)
--{
-- ClientConfiguration configuration = makeClientConfigurationWithProxy();
-- auto httpClient = CreateHttpClient(configuration);
-- makeRandomHttpRequest(httpClient, true); // we expect it to try to use proxy that is invalid
--}
-+//TEST(HttpClientTest, TestRandomURLWithProxy)
-+//{
-+// ClientConfiguration configuration = makeClientConfigurationWithProxy();
-+// auto httpClient = CreateHttpClient(configuration);
-+// makeRandomHttpRequest(httpClient, true); // we expect it to try to use proxy that is invalid
-+//}
-
- TEST(HttpClientTest, TestRandomURLWithProxyAndDeclaredAsNonProxyHost)
- {
-@@ -119,14 +119,14 @@ TEST(HttpClientTest, TestRandomURLWithProxyAndDeclaredParentDomainAsNonProxyHost
- makeRandomHttpRequest(httpClient, false);
- }
-
--TEST(HttpClientTest, TestRandomURLWithProxyAndOtherDeclaredAsNonProxyHost)
--{
-- ClientConfiguration configuration = makeClientConfigurationWithProxy();
-- configuration.nonProxyHosts = Aws::Utils::Array<Aws::String>(1);
-- configuration.nonProxyHosts[0] = "http://test.non.filtered.aws";
-- auto httpClient = CreateHttpClient(configuration);
-- makeRandomHttpRequest(httpClient, true);
--}
-+//TEST(HttpClientTest, TestRandomURLWithProxyAndOtherDeclaredAsNonProxyHost)
-+//{
-+// ClientConfiguration configuration = makeClientConfigurationWithProxy();
-+// configuration.nonProxyHosts = Aws::Utils::Array<Aws::String>(1);
-+// configuration.nonProxyHosts[0] = "http://test.non.filtered.aws";
-+// auto httpClient = CreateHttpClient(configuration);
-+// makeRandomHttpRequest(httpClient, true);
-+//}
-
- // TODO: Pending Fix on Windows.
- #if ENABLE_CURL_CLIENT