summaryrefslogtreecommitdiff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
authorMarius Bakke <[email protected]>2018-02-20 17:36:56 +0100
committerMarius Bakke <[email protected]>2018-02-20 17:36:56 +0100
commit7f69459aca16756f35f08049c64a1bd77d23f33e (patch)
tree1d267fb62feab89de5d97582672540cbaa37392c /gnu/packages/mpi.scm
parent4a82722a658220ec1e10f9f2d5d77407d38db90e (diff)
parentb1989c12501e880afab62d3ff961791906fef350 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index d9a2094bea..442f7c5371 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015 Eric Bavier <[email protected]>
-;;; Copyright © 2014, 2015, 2016, 2017 Ludovic Courtès <[email protected]>
+;;; Copyright © 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <[email protected]>
;;; Copyright © 2014 Ian Denhardt <[email protected]>
;;; Copyright © 2016 Andreas Enge <[email protected]>
;;; Copyright © 2017 Dave Love <[email protected]>
@@ -39,9 +39,12 @@
#:use-module (gnu packages ncurses)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages valgrind)
+ #:use-module (srfi srfi-1)
#:use-module (ice-9 match))
(define-public hwloc
+ ;; Note: For now we keep 1.x as the default because many packages have yet
+ ;; to migrate to 2.0.
(package
(name "hwloc")
(version "1.11.8")
@@ -110,6 +113,24 @@ a powerful programming interface to gather information about the hardware,
bind processes, and much more.")
(license bsd-3)))
+(define-public hwloc-2.0
+ ;; Note: 2.0 isn't the default yet, see above.
+ (package
+ (inherit hwloc)
+ (version "2.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.open-mpi.org/software/hwloc/v"
+ (version-major+minor version)
+ "/downloads/hwloc-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "021765f9y6pxcxrvfpzzwaig16ypfbph5xjpkd29qkhzs9r6zrcr"))
+ (patches (search-patches "hwloc-tests-without-sysfs.patch"))))
+
+ ;; libnuma is no longer needed.
+ (inputs (alist-delete "numactl" (package-inputs hwloc)))))
+
(define-public openmpi
(package
(name "openmpi")