summaryrefslogtreecommitdiff
path: root/gnu/packages/maven.scm
diff options
context:
space:
mode:
authorMarius Bakke <[email protected]>2019-02-14 00:20:28 +0100
committerMarius Bakke <[email protected]>2019-02-14 00:20:28 +0100
commit6901878894e9c6405fa811c512a32f448e8b9fa2 (patch)
tree5b04c4234f4022533692c36a83047ec9801aada9 /gnu/packages/maven.scm
parentbaf766a7ff9db45c707b4539176f2143fbd90efd (diff)
parent58c6a93d9d60660d8425d8c52d4b73a42d4a5b55 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/maven.scm')
-rw-r--r--gnu/packages/maven.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/maven.scm b/gnu/packages/maven.scm
index 5379eb9166..2d7d54dd9d 100644
--- a/gnu/packages/maven.scm
+++ b/gnu/packages/maven.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Julien Lepiller <[email protected]>
+;;; Copyright © 2019 Tobias Geerinckx-Rite <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20,6 +21,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix utils)
#:use-module (guix build-system ant)
#:use-module (gnu packages)
@@ -79,12 +81,14 @@ provides the Maven plugin generating the component metadata.")))
(name "maven-resolver-api")
(version "1.3.1")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/apache/maven-resolver/"
- "archive/maven-resolver-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/apache/maven-resolver.git")
+ (commit (string-append "maven-resolver-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0gfkf8g5zbjh6ciq3dnby9m5irhrbyc7d2jzic9l8xx6hl61q6mm"))))
+ "1x1gll8nkfl6zgnab78fxxvvhg42b2grxgdh1wp2h4qxsjkxg93d"))))
(build-system ant-build-system)
(arguments
`(#:jar-name "maven-resolver-api.jar"