summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorTanguy Le Carrour <[email protected]>2025-02-12 14:47:02 +0100
committerSharlatan Hellseher <[email protected]>2025-02-12 21:58:34 +0000
commitd0c2dc4ed1b4a8df8600e59a2c6906e375255ccc (patch)
treebab7f0cc23b01cbe3f261fc72297a0a420acea8c /gnu/packages/mail.scm
parentc9abfacd9f58f7365668b67a8125640b7497932a (diff)
gnu: aerc: Update to 0.20.1.
* gnu/packages/mail.scm (aerc): Update to 0.20.1. [source]: Drop patch fixing a now solved problem with gpg-signed messages. [arguments] <build-flags>: Remove redundant "-tags=notmuch" as it's picked by 'install phase. [phases] {install}: Pass the build flag using an environment variable. [inputs]: Remove a comment. [native-inputs]: Remove go-git-sr-ht-rjarry-go-opt; add go-git-sr-ht-rjarry-go-opt-v2. Change-Id: I71cc1330233e03996de914027f3d4d76b280acb4 Signed-off-by: Sharlatan Hellseher <[email protected]>
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm25
1 files changed, 7 insertions, 18 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index dd8a7cd218..355fb964e3 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -59,6 +59,7 @@
;;; Copyright © 2024 Jean Simard <[email protected]>
;;; Copyright © 2024 Zheng Junjie <[email protected]>
;;; Copyright © 2024 Ashish SHUKLA <[email protected]>
+;;; Copyright © 2025 Tanguy Le Carrour <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5069,7 +5070,7 @@ remote SMTP server.")
(define-public aerc
(package
(name "aerc")
- (version "0.18.2")
+ (version "0.20.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -5078,26 +5079,14 @@ remote SMTP server.")
(file-name (git-file-name name version))
(sha256
(base32
- "0y34cv2vcwhr0vbd1ax2hv9rmv79dp9i02y2xqyr23krfb5bp197"))
- (patches
- (list
- ;; patch from upstream to fix encoding problem with sending
- ;; gpg-signed messages
- ;; see https://todo.sr.ht/~rjarry/aerc/79
- (origin
- (method url-fetch)
- (uri "https://git.sr.ht/~rjarry/aerc/commit/7346d20.patch")
- (file-name "aerc-fix-gpg-signed-message-encoding.patch")
- (sha256 (base32
- "14avr323sr9qipf9d7npqwrzq37i9946z9m6jdkzi8n9rs6zwzq9")))))))
+ "04412inhzj8vwybafqz6nw8wrsyf51zjv0881aacr6zc9bfcq510"))))
(build-system go-build-system)
(arguments
(list #:import-path "git.sr.ht/~rjarry/aerc"
;; Installing the source is only necessary for Go libraries.
#:install-source? #f
#:build-flags
- #~(list "-tags=notmuch"
- (string-append
+ #~(list (string-append
"-ldflags=-X main.Version=" #$version
" -X git.sr.ht/~rjarry/aerc/config.libexecDir="
#$output "/libexec/aerc"
@@ -5136,20 +5125,20 @@ remote SMTP server.")
(string-append "src/" import-path))))
(replace 'install
(lambda* (#:key import-path build-flags #:allow-other-keys)
- (invoke "make" "CC=gcc" "install" "-C"
+ (invoke "make" "CC=gcc" "GOFLAGS=-tags=notmuch" "install" "-C"
(string-append "src/" import-path)
(string-append "PREFIX=" #$output)))))))
(inputs
(append
(list gnupg
- notmuch ; Failing to build without it.
+ notmuch
python
python-vobject)
(if (supported-package? zoxide)
(list zoxide)
'())))
(native-inputs
- (list go-git-sr-ht-rjarry-go-opt
+ (list go-git-sr-ht-rjarry-go-opt-v2
go-git-sr-ht-rockorager-go-jmap
go-git-sr-ht-rockorager-vaxis
go-github-com-protonmail-go-crypto