summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorGreg Hogan <[email protected]>2021-01-12 19:56:31 +0000
committerEfraim Flashner <[email protected]>2021-01-28 20:03:58 +0200
commitc02cad6d334f768f131f006c1a81c07954d872c6 (patch)
treea4c2f9acac1cf946bc0b6566aedb7ec7b805800e /gnu/packages/linux.scm
parent34861ac8eae3935b19b387545ca3c4c311fb66e7 (diff)
gnu: libbpf: Update to 0.1.1.
* gnu/packages/linux.scm (libbpf): Update to 0.1.1. [arguments]: Remove obsolete deletion. Signed-off-by: Efraim Flashner <[email protected]>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2735c67200..84f23426aa 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -49,7 +49,7 @@
;;; Copyright © 2020 Michael Rohleder <[email protected]>
;;; Copyright © 2020 Anders Thuné <[email protected]>
;;; Copyright © 2020 Maxim Cournoyer <[email protected]>
-;;; Copyright © 2020 Greg Hogan <[email protected]>
+;;; Copyright © 2020, 2021 Greg Hogan <[email protected]>
;;; Copyright © 2020 Zhu Zihao <[email protected]>
;;; Copyright © 2020 David Dashyan <[email protected]>
;;; Copyright © 2020 pukkamustard <[email protected]>
@@ -7587,7 +7587,7 @@ persistent over reboots.")
(define-public libbpf
(package
(name "libbpf")
- (version "0.0.9")
+ (version "0.1.1")
(source
(origin
(method git-fetch)
@@ -7597,7 +7597,7 @@ persistent over reboots.")
(file-name (git-file-name name version))
(sha256
(base32
- "18l0gff7nm841mwhr7bc7x863xcyvwh58zl7mc0amnsjqlbrvqg7"))))
+ "0ilnnm4q22f8fagwp8kb37licy4ks861i2iqh2djsypqhnxvx3fv"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -7617,10 +7617,7 @@ persistent over reboots.")
(modify-phases %standard-phases
(delete 'configure)
(add-before 'build 'pre-build
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "scripts/check-reallocarray.sh"
- (("/bin/rm" rm)
- (string-append (assoc-ref inputs "coreutils") rm)))
+ (lambda _
(chdir "src")
#t)))))
(home-page "https://github.com/libbpf/libbpf")