summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2025-01-03 14:32:07 -0500
committerLeo Famulari <leo@famulari.name>2025-01-04 12:19:36 -0500
commit7b40b9d2d2ddafd6945f18f19f5e621086d57169 (patch)
tree7a4f6a94070b05680d3714ab521aee2f441e2c22 /gnu/packages/linux.scm
parent321edcf0744a8895690579e8a5b09b66c75d102c (diff)
gnu: Remove linux-libre 4.19.
This kernel series is no longer supported upstream. * gnu/packages/linux.scm (linux-libre-4.19-version, linux-libre-4.19-gnu-revision, deblob-scripts-4.19, linux-libre-4.19-pristine-source, linux-libre-4.19-source, linux-libre-headers-4.19, linux-libre-4.19, linux-libre-arm-generic-4.19, linux-libre-arm-omap2plus-4.19): Remove variables. * gnu/tests/base.scm (%test-linux-libre-4.19): Remove variable. * gnu/packages/aux-files/linux-libre/4.19-arm.conf, gnu/packages/aux-files/linux-libre/4.19-arm64.conf, gnu/packages/aux-files/linux-libre/4.19-i686.conf, gnu/packages/aux-files/linux-libre/4.19-x86_64.conf: Delete files. * Makefile.am (AUX_FILES): Remove them. Change-Id: If79ccbb948975c544b27757104d360539970377c
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm49
1 files changed, 0 insertions, 49 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1a11646edf..f5c7ab19c8 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -608,21 +608,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(%upstream-linux-source version hash)
deblob-scripts-5.4)))
-(define-public linux-libre-4.19-version "4.19.325")
-(define-public linux-libre-4.19-gnu-revision "gnu1")
-(define deblob-scripts-4.19
- (linux-libre-deblob-scripts
- linux-libre-4.19-version
- linux-libre-4.19-gnu-revision
- (base32 "0pjal2cc2f99cvw8r4icb4l24j41k48jkj6bqk7pcahzcgx33ycb")
- (base32 "048isws4h3lya8dwpwyhqglsjg9sckxk0gfsxdbqg336n5vi0gb1")))
-(define-public linux-libre-4.19-pristine-source
- (let ((version linux-libre-4.19-version)
- (hash (base32 "1qcd1rrv96p9iz9a9qpx3b9rm2jyps6sgj7l7m21m8ydwmyysyv0")))
- (make-linux-libre-source version
- (%upstream-linux-source version hash)
- deblob-scripts-4.19)))
-
(define %boot-logo-patch
;; Linux-Libre boot logo featuring Freedo and a gnu.
(origin
@@ -688,11 +673,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(search-patch
"linux-libre-support-for-Pinebook-Pro.patch"))))
-(define-public linux-libre-4.19-source
- (source-with-patches linux-libre-4.19-pristine-source
- (list %boot-logo-patch
- %linux-libre-arm-export-__sync_icache_dcache-patch)))
-
;;;
;;; Kernel headers.
@@ -807,11 +787,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
linux-libre-5.4-gnu-revision
linux-libre-5.4-source))
-(define-public linux-libre-headers-4.19
- (make-linux-libre-headers* linux-libre-4.19-version
- linux-libre-4.19-gnu-revision
- linux-libre-4.19-source))
-
;; The following package is used in the early bootstrap, and thus must be kept
;; stable and with minimal build requirements.
(define-public linux-libre-headers-5.15.49
@@ -1197,14 +1172,6 @@ Linux kernel. It has been modified to remove all non-free binary blobs.")
"aarch64-linux" "powerpc64le-linux" "riscv64-linux")
#:configuration-file kernel-config))
-(define-public linux-libre-4.19
- (make-linux-libre* linux-libre-4.19-version
- linux-libre-4.19-gnu-revision
- linux-libre-4.19-source
- '("x86_64-linux" "i686-linux" "armhf-linux"
- "aarch64-linux" "powerpc64le-linux")
- #:configuration-file kernel-config))
-
;; Linux-Libre-LTS points to the *newest* released long-term support version of
;; Linux-Libre.
;; Reference: <https://www.kernel.org/category/releases.html>
@@ -1259,14 +1226,6 @@ Linux kernel. It has been modified to remove all non-free binary blobs.")
("CONFIG_RTC_DRV_RK808" . #t))
(default-extra-linux-options linux-libre-5.4-version))))
-(define-public linux-libre-arm-generic-4.19
- (make-linux-libre* linux-libre-4.19-version
- linux-libre-4.19-gnu-revision
- linux-libre-4.19-source
- '("armhf-linux")
- #:defconfig "multi_v7_defconfig"
- #:extra-version "arm-generic"))
-
(define-public linux-libre-arm-omap2plus
(make-linux-libre* linux-libre-version
linux-libre-gnu-revision
@@ -1275,14 +1234,6 @@ Linux kernel. It has been modified to remove all non-free binary blobs.")
#:defconfig "omap2plus_defconfig"
#:extra-version "arm-omap2plus"))
-(define-public linux-libre-arm-omap2plus-4.19
- (make-linux-libre* linux-libre-4.19-version
- linux-libre-4.19-gnu-revision
- linux-libre-4.19-source
- '("armhf-linux")
- #:defconfig "omap2plus_defconfig"
- #:extra-version "arm-omap2plus"))
-
(define-public linux-libre-arm64-generic
(make-linux-libre* linux-libre-version
linux-libre-gnu-revision