summaryrefslogtreecommitdiff
path: root/gnu/packages/libunwind.scm
diff options
context:
space:
mode:
authorMarius Bakke <[email protected]>2022-07-22 01:09:14 +0200
committerMarius Bakke <[email protected]>2022-07-22 01:09:14 +0200
commit9044b086ddca64a62966a83cbf1b82d32dece89e (patch)
tree2c7f910c9100b2f2a752d07fe0ec44be83fb7600 /gnu/packages/libunwind.scm
parent5dfc6ab1ab292b87ceea144aa661d0e64c834031 (diff)
parentabea091dbef2d44e6eb46bd2413bdf917e14d095 (diff)
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/libunwind.scm')
-rw-r--r--gnu/packages/libunwind.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/libunwind.scm b/gnu/packages/libunwind.scm
index 9eaf26fca8..8b9f800711 100644
--- a/gnu/packages/libunwind.scm
+++ b/gnu/packages/libunwind.scm
@@ -2,6 +2,8 @@
;;; Copyright © 2013, 2014 Ludovic Courtès <[email protected]>
;;; Copyright © 2015 Mark H Weaver <[email protected]>
;;; Copyright © 2019 Tobias Geerinckx-Rice <[email protected]>
+;;; Copyright © 2022 Efraim Flashner <[email protected]>
+;;; Copyright © 2022 Marius Bakke <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,20 +30,20 @@
(define-public libunwind
(package
(name "libunwind")
- (version "1.5.0")
+ (version "1.6.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/libunwind/libunwind-"
version ".tar.gz"))
(sha256
(base32
- "05qhzcg1xag3l5m3c805np6k342gc0f3g087b7g16jidv59pccwh"))))
+ "0xj9g6a9q7v7zz6lymf3f6011synibgawi4wi384bywid5kfqsja"))))
(build-system gnu-build-system)
(arguments
- ;; FIXME: As of glibc 2.25, we get 1 out of 34 test failures (2 are
- ;; expected to fail).
- ;; Report them upstream.
- '(#:tests? #f))
+ '(#:make-flags
+ ;; Two tests are failing with newer toolchains:
+ ;; https://github.com/libunwind/libunwind/issues/363
+ '("XFAIL_TESTS=run-coredump-unwind run-coredump-unwind-mdi")))
(home-page "https://www.nongnu.org/libunwind")
(synopsis "Determining the call chain of a program")
(description