summaryrefslogtreecommitdiff
path: root/gnu/packages/julia.scm
diff options
context:
space:
mode:
authorMarius Bakke <[email protected]>2018-02-20 17:36:56 +0100
committerMarius Bakke <[email protected]>2018-02-20 17:36:56 +0100
commit7f69459aca16756f35f08049c64a1bd77d23f33e (patch)
tree1d267fb62feab89de5d97582672540cbaa37392c /gnu/packages/julia.scm
parent4a82722a658220ec1e10f9f2d5d77407d38db90e (diff)
parentb1989c12501e880afab62d3ff961791906fef350 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/julia.scm')
-rw-r--r--gnu/packages/julia.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index f6df2817d3..41bbc66dd2 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -146,6 +146,12 @@
(lambda* (#:key inputs #:allow-other-keys)
(use-modules (ice-9 match))
(substitute* "src/runtime_ccall.cpp"
+ ;; Patch out invocations of '/sbin/ldconfig' to avoid getting
+ ;; error messages about missing '/sbin/ldconfig' on GuixSD.
+ (("popen\\(.*ldconfig.*\\);")
+ "NULL;\n")
+
+ ;; Populate 'sonameMap'.
(("jl_read_sonames.*;")
(string-join
(map (match-lambda
@@ -228,6 +234,12 @@
#t))
(add-before 'check 'disable-broken-tests
(lambda _
+ ;; Adjust expected error messages to match what current libgit2
+ ;; provides.
+ (substitute* "test/libgit2.jl"
+ (("Invalid Content-Type") "invalid Content-Type")
+ (("Failed to resolve path") "failed to resolve path"))
+
(substitute* "test/choosetests.jl"
;; These tests fail, probably because some of the input
;; binaries have been stripped and thus backtraces don't look