summaryrefslogtreecommitdiff
path: root/gnu/packages/inkscape.scm
diff options
context:
space:
mode:
authorMark H Weaver <[email protected]>2018-05-17 01:00:50 -0400
committerMark H Weaver <[email protected]>2018-05-17 01:00:50 -0400
commit539bf8f2c071b53834829259bb3fabf0390c5dc6 (patch)
tree16672732afbf4c3f933e67ac677aa1877f6a7657 /gnu/packages/inkscape.scm
parent903874328ed5e5ab766e36cee1b1a0989e8b24a9 (diff)
parent2cf8531f360ef390d3ec670cc150b106bab5eff1 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/inkscape.scm')
-rw-r--r--gnu/packages/inkscape.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index ffd5f60b38..de9940df1c 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -80,8 +80,13 @@
;; FIXME: tests require gmock
(arguments
`(#:tests? #f
- #:make-flags
- '("gtk_update_icon_cache=true")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-icon-cache-generator
+ (lambda _
+ (substitute* "share/icons/application/CMakeLists.txt"
+ (("gtk-update-icon-cache") "true"))
+ #t)))))
(home-page "https://inkscape.org/")
(synopsis "Vector graphics editor")
(description "Inkscape is a vector graphics editor. What sets Inkscape