summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-24 11:48:58 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:19 +0000
commitc26e1438383e4937db814e9f78c50eae14858631 (patch)
tree0744ea71d43cc41c468b646a265c7f144917d3ae /gnu/packages/golang.scm
parent6c3144c958204da4e579361b2ae4ce748bed1427 (diff)
gnu: go-github-com-mitchellh-go-homedir: Update to 1.1.0.
* gnu/packages/golang.scm (go-github-com-mitchellh-go-homedir): Update to 1.1.0. Change-Id: I709e3dd146bfb972a89ca4cdd742261ce908e2a1
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 604b93b67f..af797f2c08 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3720,21 +3720,19 @@ required by Go's standard Hash interface.")
(license license:expat))))
(define-public go-github-com-mitchellh-go-homedir
- (let ((commit "ae18d6b8b3205b561c79e8e5f69bff09736185f4")
- (revision "0"))
(package
(name "go-github-com-mitchellh-go-homedir")
- (version (git-version "1.0.0" revision commit))
+ (version "1.1.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/mitchellh/go-homedir")
- (commit commit)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "0f0z0aa4wivk4z1y503dmnw0k0g0g403dly8i4q263gfshs82sbq"))))
+ "0ydzkipf28hwj2bfxqmwlww47khyk6d152xax4bnyh60f4lq3nx1"))))
(build-system go-build-system)
(arguments
(quote (#:import-path "github.com/mitchellh/go-homedir"
@@ -3756,7 +3754,7 @@ package cannot cross compile. But 99% of the time the use for
@command{os/user} is just to retrieve the home directory, which we can do for
the current user without cgo. This library does that, enabling
cross-compilation.")
- (license license:expat))))
+ (license license:expat)))
(define-public go-github-com-mitchellh-reflectwalk
(package