summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSarah Morgensen <[email protected]>2024-08-29 00:50:47 +0100
committerSharlatan Hellseher <[email protected]>2024-09-03 15:42:59 +0100
commitd4da8af4e4aaf165ed384ff71d23dcce56554cf0 (patch)
treef07642554e5e935e9d5ef6e32f9423dc38864260 /gnu/packages/golang-xyz.scm
parent5147787b1fae6b06bd6c1e3ebc66ea4328420746 (diff)
gnu: Add go-github-com-godbus-dbus-v5.
These changes resolve issues with golang import paths for <github.com/godbus/dbus> and <github.com/godbus/dbus/v5> by adding a new variable with downgrading existing one to the latest version where import path is still <github.com/godbus/dbus>. It addresses the cases with unit tests failures and help importer to resolve dependencies. * gnu/packages/golang.scm (go-github-com-godbus-dbus): Downgrade to 0.0.0-20190726142602-4481cbc300e2. (go-github-com-godbus-dbus-v5): New variable, preserver version of go-github-com-godbus-dbus. (go-github-com-delthas-go-libnp) [propagated-inputs]: Remove go-github-com-godbus-dbus, add go-github-com-godbus-dbus-v5. * gnu/packages/golang-xyz.scm (go-github-com-coreos-go-systemd-v22) [propagated-inputs]: Remove go-github-com-godbus-dbus, add go-github-com-godbus-dbus-v5. Change-Id: Idbeb3c625da55bdd4620afab31b024ef0a0b79ec Co-authored-by: Sharlatan Hellseher <[email protected]> Signed-off-by: Sharlatan Hellseher <[email protected]>
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 796341a66b..5e66c9e082 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1611,7 +1611,7 @@ throughput.")
(inputs
(list elogind))
(propagated-inputs
- (list go-github-com-godbus-dbus))
+ (list go-github-com-godbus-dbus-v5))
(home-page "https://github.com/coreos/go-systemd")
(synopsis "Go bindings to systemd")
(description