summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-28 15:39:25 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:32 +0000
commit516e9be0009123396d3a513ca6b951c1dddd034d (patch)
tree05a84464247df11dfbb736696d026c40a7be3e19 /gnu/packages/golang-xyz.scm
parent5416958ba161d86886c09e5477d002786237f5d9 (diff)
gnu: go-github-com-gorhill-cronexpr: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-gorhill-cronexpr): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I21a1b8a4cbb4ec2f3db1bf93d66fe20430395fdf
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 90c2d02345..ab0a19b2a0 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -5088,6 +5088,32 @@ underneath and returns only matching files or direcories, depending on the
configuration.")
(license license:expat)))
+(define-public go-github-com-gorhill-cronexpr
+ (package
+ (name "go-github-com-gorhill-cronexpr")
+ (version "0.0.0-20180427100037-88b0669f7d75")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gorhill/cronexpr")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0hc7xdfclp2qgkr1581jb3ckjvl34nxmqrnraci5jzmqx5av9j1r"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/gorhill/cronexpr"))
+ (home-page "https://github.com/gorhill/cronexpr")
+ (synopsis "Cron expression parser in the Go language")
+ (description
+ "This package provides a cron expression parser in the Go language.
+Given a cron expression and a time stamp, you can get the next time stamp
+which satisfies the cron expression.")
+ (license (list license:gpl3+
+ license:asl2.0))))
+
(define-public go-github-com-hanwen-go-fuse
(package
(name "go-github-com-hanwen-go-fuse")