summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-31 17:50:58 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-01-21 23:42:41 +0000
commitf27a0237d21a5d7af034b0c70a3e4607fdca65de (patch)
tree4dd2eb7ad9633b408b872c69782274fc1df0e584 /gnu/packages/golang-web.scm
parent38228e03ab88b0616d6fc9cfe67b74fc6a5ff2fd (diff)
gnu: Add go-github-com-gorilla-schema.
* gnu/packages/golang-web.scm (go-github-com-gorilla-schema): New variable. Change-Id: Ie31e0c3f7127c44be5de59b3509467f5429db8c4
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 580d77e9bd..e7440f8ad4 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -3291,6 +3291,30 @@ web applications.")
incoming requests with their respective handler.")
(license license:bsd-3)))
+(define-public go-github-com-gorilla-schema
+ (package
+ (name "go-github-com-gorilla-schema")
+ (version "1.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gorilla/schema")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16gk174mybvz0gg2w1wmpc96jhhi94i1vvclyzr3qkv7s6gadifn"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/gorilla/schema"))
+ (home-page "https://github.com/gorilla/schema")
+ (synopsis "Fills a struct with form values")
+ (description
+ "This package implements a functionality to fills a struct with form
+values.")
+ (license license:bsd-3)))
+
(define-public go-github-com-gorilla-securecookie
(package
(name "go-github-com-gorilla-securecookie")