summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-30 13:02:11 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:39 +0000
commit8b0e4b8ef6f27a30ebe6f99f29b198e0add72cb4 (patch)
tree13e4155a4c0b195a9664929d411284b56485a5cc /gnu/packages/golang-web.scm
parent7e8d58423784c770ddfb76a98db331c9466d7752 (diff)
gnu: Add go-github-com-aws-smithy-go-codegen.
* gnu/packages/golang-web.scm (go-github-com-aws-smithy-go-codegen): New variable. Change-Id: I69fe6b5f7306c6200e94ca7f875f948da0c5a006
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index b82144e2e5..e2cf9d11fd 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -681,6 +681,32 @@ credentials sources.")
signing.")
(license license:asl2.0)))
+(define-public go-github-com-aws-smithy-go-codegen
+ (package
+ (name "go-github-com-aws-smithy-go-codegen")
+ (version "0.0.0-20241226171254-10fbeed6f845")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aws/smithy-go")
+ (commit (go-version->git-ref version
+ #:subdir "codegen"))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16jbv7cyj85048f4kcrib8k2yif165sc099h0aklal5dwlf85xcg"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:skip-build? #t
+ #:import-path "github.com/aws/smithy-go/codegen"
+ #:unpack-path "github.com/aws/smithy-go"))
+ (home-page "https://github.com/aws/smithy-go")
+ (synopsis "Smithy code generators for Golang")
+ (description
+ "This package provides Gradle templates for Smithy code generators.")
+ (license license:asl2.0)))
+
(define-public go-github-com-aymerick-douceur
(package
(name "go-github-com-aymerick-douceur")