summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-26 21:28:32 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-01-21 23:42:24 +0000
commit190b3a5ba35cce964255acbdb7362da860fd0ddc (patch)
tree5b9206a3312d44d87ca3d72ff1ef784390b96bef /gnu/packages/golang-web.scm
parent4d4e7af574d99698fcc34c1ff4b48960186546cf (diff)
gnu: Add go-github-com-gobwas-httphead.
* gnu/packages/golang-web.scm (go-github-com-gobwas-httphead): New variable. Change-Id: I2b116bae78ec56c42504c046873caed7102ff201
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 3163f8dcd2..db37d81362 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2557,6 +2557,30 @@ from CloudFlare's github.com/cloudflare/cfssl/revoke.")
;; For the WebAuthn's fork: LICENSE.
license:bsd-3))))
+(define-public go-github-com-gobwas-httphead
+ (package
+ (name "go-github-com-gobwas-httphead")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gobwas/httphead")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "106l8ml5yihld3rrf45q5fhlsx64hrpj2dsvnnm62av4ya5nf0gb"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/gobwas/httphead"))
+ (home-page "https://github.com/gobwas/httphead")
+ (synopsis "Tiny HTTP header value parsing library in Golang")
+ (description
+ "Package httphead contains utils for parsing HTTP and HTTP-grammar
+compatible text protocols headers.")
+ (license license:expat)))
+
(define-public go-github-com-goccy-go-json
(package
(name "go-github-com-goccy-go-json")