summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-19 16:52:24 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:08 +0000
commitfd0586d9c5aa936402cc4260c4cf7e5faacbe1ba (patch)
tree403549be1db41af5299b218f5c1e0dca98176de2 /gnu/packages/golang-check.scm
parent4e654723da09d41af2294e33d65d229d03f6c759 (diff)
gnu: Add go-github-com-maxatome-go-testdeep.
* gnu/packages/golang-check.scm (go-github-com-maxatome-go-testdeep): New variable. Change-Id: I73ef16e2b98f28f91f0e05f03be353219f746ddc
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index e4c868b1a4..812d59b286 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -921,6 +921,34 @@ output capturing, mocking, and much more.")
testing capabilities.")
(license license:expat)))
+(define-public go-github-com-maxatome-go-testdeep
+ (package
+ (name "go-github-com-maxatome-go-testdeep")
+ (version "1.14.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/maxatome/go-testdeep")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0r9w79qm6j080gbqhrd5gwjzsnkmrcihy4yniw77g0wkspxxdjww"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/maxatome/go-testdeep"
+ ;; Structure comparison not equal.
+ #:test-flags #~(list "-skip" "TestFatalTrace")))
+ (propagated-inputs
+ (list go-github-com-davecgh-go-spew))
+ (home-page "https://github.com/maxatome/go-testdeep")
+ (synopsis "Extended HTTP API testing framework")
+ (description
+ "Package testdeep allows flexible deep comparison, it is an adaptation of
+Perl's @url{https://metacpan.org/pod/Test::Deep, Test::Deep perl}.")
+ (license license:bsd-2)))
+
(define-public go-github-com-onsi-ginkgo
(package
(name "go-github-com-onsi-ginkgo")