summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-16 11:06:56 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:04 +0000
commitb3d13110643eb11cf7fbdf9408a7a5f67c335e16 (patch)
tree476347d1c7b7eced577e4721c9c22f7c540659e1 /gnu/packages/golang-check.scm
parent3405000aa41c9c4b949a87e24029888804eb5ef7 (diff)
gnu: go-github-com-onsi-gomega: Enable tests.
* gnu/packages/golang-check.scm (go-github-com-onsi-gomega) [arguments]<tests?>: Enable them. <phases>: Add 'remove-failing-test-files. [native-inputs]: Add go-github-com-onsi-ginkgo-v2-bootstrap. (go-github-com-onsi-ginkgo-v2-bootstrap): New variable. Change-Id: I631cf5e1ed46822a0585387f20169084578d19f4
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm26
1 files changed, 22 insertions, 4 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index f9a6f3f8d7..161740b8e8 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -951,6 +951,19 @@ Gomega matcher library.")
go-golang-org-x-sys
go-golang-org-x-tools))))
+(define-public go-github-com-onsi-ginkgo-v2-bootstrap
+ (hidden-package (package (inherit go-github-com-onsi-ginkgo-v2)
+ (name "go-github-com-onsi-ginkgo-v2")
+ (arguments
+ (list
+ #:tests? #f
+ #:import-path "github.com/onsi/ginkgo/v2"
+ #:phases
+ #~(modify-phases %standard-phases (delete 'build))))
+ (native-inputs '())
+ (propagated-inputs
+ (list go-github-com-go-logr-logr)))))
+
(define-public go-github-com-onsi-gomega
(package
(name "go-github-com-onsi-gomega")
@@ -967,10 +980,15 @@ Gomega matcher library.")
(build-system go-build-system)
(arguments
(list
- ;; Unless we disable the tests, we have a circular dependency on
- ;; ginkgo/v2.
- #:tests? #f
- #:import-path "github.com/onsi/gomega"))
+ #:import-path "github.com/onsi/gomega"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-failing-test-files
+ (lambda* (#:key import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (delete-file "gexec/build_test.go")))))))
+ (native-inputs
+ (list go-github-com-onsi-ginkgo-v2-bootstrap))
(propagated-inputs
(list go-github-com-golang-protobuf
go-golang-org-x-net