summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-03 19:43:43 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:41:49 +0000
commit936c9013e7ed32eb167fb750fc2a23fe0b39c23d (patch)
treed3f0e6ef957eab88a9166f3eb329a526f5e06eb2 /gnu/packages/golang-check.scm
parent1a6b25806fe0d9cf57b839e4fc6e4343b3f833ad (diff)
gnu: go-gopkg-in-check-v1: Disable tests.
* gnu/packages/golang-check.scm (go-gopkg-in-check-v1) [arguments]<tests?>: Disable them. <phases>: Remove custom 'check as redundant. Change-Id: I9714e7ea019923f50ecb61097f90101326e5c4c8
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm14
1 files changed, 5 insertions, 9 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 4831bb02c7..293ed1fc5a 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -1277,6 +1277,8 @@ real database connection.")
reformat the source code, it only prints out style mistakes.")
(license license:bsd-3))))
+;; XXX: Unmaintained since 2020, see
+;; <https://github.com/go-check/check/issues/111>.
(define-public go-gopkg-in-check-v1
(package
(name "go-gopkg-in-check-v1")
@@ -1294,15 +1296,9 @@ reformat the source code, it only prints out style mistakes.")
(build-system go-build-system)
(arguments
(list
- #:import-path "gopkg.in/check.v1"
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs #:allow-other-keys #:rest args)
- (unless
- ;; The tests fail when run with gccgo.
- (false-if-exception (search-input-file inputs "/bin/gccgo"))
- (apply (assoc-ref %standard-phases 'check) args)))))))
+ ;; Most tests failed.
+ #:tests? #f
+ #:import-path "gopkg.in/check.v1"))
(propagated-inputs
(list go-github-com-kr-pretty))
(home-page "https://gopkg.in/check.v1")