summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-27 21:23:33 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-01-21 23:42:30 +0000
commit82f5ca3ecb9dc9fb1cac1c990c31266817a822cc (patch)
tree66ca716e169404720b739373cbf06c8a3b85d64a /gnu/packages/golang-check.scm
parent0cd8106fe91401357135572707f1ec57567dbf76 (diff)
gnu: go-github-com-smarty-gunit: Fix tests.
* gnu/packages/golang-check.scm (go-github-com-smarty-gunit) [arguments] <test-flags>: Skip one test. Change-Id: I83f00b9f43af9d0e45694d740b7864544a6791f0
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index be4037f517..2e408226e0 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -1460,7 +1460,13 @@ functions and even in applications.")
(build-system go-build-system)
(arguments
(list
- #:import-path "github.com/smarty/gunit"))
+ #:import-path "github.com/smarty/gunit"
+ ;; Expected: [&{ BowlingGameScoringTests [0xc000080020
+ ;; 0xc000080040 0xc000080060 0xc000080080 0xc0000800a0]}]
+ ;; Actual: [&{ BowlingGameScoringTests [0xc0000da920
+ ;; 0xc0000da940 0xc0000da960 0xc0000da9a0 0xc0000da9c0]}]
+ #:test-flags
+ #~(list "-skip" "TestParseFileWithValidFixturesAndConstructs")))
(home-page "https://github.com/smarty/gunit")
(synopsis "Golang xUnit-style test fixture test adapter")
(description