summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-19 13:00:10 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:08 +0000
commit74eea25303dd8cfd6a8b6c4c1d34451e935685a3 (patch)
tree44dfc19a6d25ba426015a2fabb0a9b41dfc51872 /gnu/packages/golang-check.scm
parent5b2176105e74b563711925798327d1484234eb18 (diff)
gnu: go-github-com-jackc-pgconn: Enable tests.
* gnu/packages/golang-xyz.scm (go-github-com-jackc-pgconn) [arguments] <tests?>: Activate them. <test-flags>: Skip 9 tests. <phases>: Add 'remove-failing-test-file. [native-inputs]: Add go-github-com-jackc-pgmock. [propagated-inputs]: Remove go-github-com-jackc-pgmock. * gnu/packages/golang-check.scm (go-github-com-jackc-pgmock-bootstrap): New variable. Change-Id: Ice47b75770fb596734f6703c3c42dbfe3e91a7a6
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 108db31883..4881c4f886 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -704,6 +704,18 @@ used in go-github-com-jackc-pgx.")
"This package implements a functionality to mock a PostgreSQL server.")
(license license:expat)))
+(define-public go-github-com-jackc-pgmock-bootstrap
+ (hidden-package
+ (package
+ (inherit go-github-com-jackc-pgmock)
+ (arguments
+ (list #:tests? #f
+ #:import-path "github.com/jackc/pgmock"
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'build))))
+ (native-inputs '()))))
+
(define-public go-github-com-jacobsa-oglematchers
(package
(name "go-github-com-jacobsa-oglematchers")