summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-06 00:13:26 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:41:51 +0000
commit6b572f4786f48716425b8e1a7bbe357e731f1f38 (patch)
tree4aaed150c7c15aee1661b3e49e40ee907f87b26e /gnu/packages/golang-check.scm
parent5d7bd9feee84a236aad727366dec312d454ee797 (diff)
gnu: Add go-gopkg-in-dnaeon-go-vcr-v4.
* gnu/packages/golang-check.scm (go-gopkg-in-dnaeon-go-vcr-v4): New variable. Change-Id: I63a48e9e5c60f22f756d885bdd3ec247f6565394
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 879f89f4e1..bd7853d362 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -1385,6 +1385,34 @@ and replaying them in future runs in order to provide fast, deterministic and
accurate testing of your code.")
(license license:bsd-2)))
+(define-public go-gopkg-in-dnaeon-go-vcr-v4
+ (package
+ (inherit go-gopkg-in-dnaeon-go-vcr-v3)
+ (name "go-gopkg-in-dnaeon-go-vcr-v4")
+ (version "4.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gopkg.in/dnaeon/go-vcr.v4")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1p1a4hbk303k2bv9dmaf770dml71zr3260g5z7yd84vzhj8i0rzb"))))
+ (arguments
+ (list
+ #:import-path "gopkg.in/dnaeon/go-vcr.v4"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: Workaround for go-build-system's lack of Go modules
+ ;; support.
+ (delete 'build)
+ (replace 'check
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))))
+
(define-public go-gopkg-in-go-playground-assert-v1
(package
(name "go-gopkg-in-go-playground-assert-v1")