summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-12 12:06:17 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:41:53 +0000
commit6179e9dda0f4b3ff6ed7ab805486d71e9e588880 (patch)
tree22746877f3c8eaa3d44b899cdf976c258b0505cc /gnu/packages/golang-check.scm
parentece4daf5fd8b087f077a4a65e831f8df9ef11518 (diff)
gnu: go-golang-org-x-lint: Fix indentation.
* gnu/packages/golang-check.scm (go-golang-org-x-lint): Fix indentation. Change-Id: I3ec261699ee31b5b8ab0dda90d5da6f9fe87a923
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm48
1 files changed, 24 insertions, 24 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 7c2b65fec9..58c7cb33a9 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -1313,30 +1313,30 @@ real database connection.")
(license license:expat)))
(define-public go-golang-org-x-lint
- (package
- (name "go-golang-org-x-lint")
- (version "0.0.0-20241112194109-818c5a804067")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://go.googlesource.com/lint")
- (commit (go-version->git-ref version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "06ni2jpd3s5bzg2qrry58svakkg9k43gkgkrbk8f8x886qnhnimp"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "golang.org/x/lint"
- #:tests? #f)) ;; TODO: Fix tests
- (propagated-inputs
- (list go-golang-org-x-tools))
- (home-page "https://golang.org/x/lint")
- (synopsis "Linter for Go source code")
- (description
- "This is a linter for Go source code. Unlike gofmt, it doesn't
-reformat the source code, it only prints out style mistakes.")
- (license license:bsd-3)))
+ (package
+ (name "go-golang-org-x-lint")
+ (version "0.0.0-20241112194109-818c5a804067")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/lint")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06ni2jpd3s5bzg2qrry58svakkg9k43gkgkrbk8f8x886qnhnimp"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "golang.org/x/lint"
+ #:tests? #f)) ;; TODO: Fix tests
+ (propagated-inputs
+ (list go-golang-org-x-tools))
+ (home-page "https://golang.org/x/lint")
+ (synopsis "Linter for Go source code")
+ (description
+ "This is a linter for Go source code. Unlike gofmt, it doesn't reformat
+the source code, it only prints out style mistakes.")
+ (license license:bsd-3)))
;; XXX: Unmaintained since 2020, see
;; <https://github.com/go-check/check/issues/111>.