summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-30 11:11:08 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:39 +0000
commit07536320d6ef8f55698cc2ba3e434d3499dfd79c (patch)
tree99a81f518cddab594d8365d828cd28c6920948af /gnu/packages/golang-check.scm
parent8f70c28459a61159bc7d12c6059ab1ba4fdb6234 (diff)
gnu: go-github-com-go-playground-validator-v10: Move to golang-check.
* gnu/packages/golang.scm (go-github-com-go-playground-validator-v10): Move from here ... * gnu/packages/golang-check.scm: ... to here. Change-Id: Idd8b93fbd1415c0cd329fad722f40cd22a0e5d4b
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 47990ec756..99ed72cb65 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -455,6 +455,59 @@ workloads. This kind of profiling is also known as wall-clock profiling.")
tests.")
(license license:expat)))
+(define-public go-github-com-go-playground-validator-v10
+ (package
+ (name "go-github-com-go-playground-validator-v10")
+ (version "10.23.0")
+ (home-page "https://github.com/go-playground/validator")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-playground/validator")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1frr06zq7fimmfjv9nac2cx9gclydbay0smn2h78znsbrylfhcmz"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/go-playground/validator/v10"))
+ (native-inputs
+ (list go-github-com-go-playground-assert-v2))
+ (propagated-inputs
+ (list go-github-com-gabriel-vasile-mimetype
+ go-github-com-go-playground-locales
+ go-github-com-go-playground-universal-translator
+ go-github-com-leodido-go-urn
+ go-golang-org-x-crypto
+ go-golang-org-x-text))
+ (synopsis "Validator for structs and individual fields based on tags")
+ (description
+ "This package implements value validations for structs and individual
+fields based on tags. It has the following unique features:
+
+@itemize
+@item Cross Field and Cross Struct validations by using validation tags or
+custom validators
+@item Slice, Array and Map diving, which allows any or all levels of a
+multidimensional field to be validated
+@item Ability to dive into both map keys and values for validation
+@item Handles type interface by determining it's underlying type prior to
+validation
+@item Handles custom field types such as sql driver
+@uref{https://golang.org/src/database/sql/driver/types.go?s=1210:1293#L29,
+Valuer}
+@item Alias validation tags, which allows for mapping of several validations
+to a single tag for easier defining of validations on structs
+@item Extraction of custom defined Field Name e.g. can specify to extract the
+JSON name while validating and have it available in the resulting FieldError
+@item Customizable i18n aware error messages.
+@item Default validator for the @uref{https://github.com/gin-gonic/gin, gin}
+web framework
+@end itemize")
+ (license license:expat)))
+
(define-public go-github-com-go-quicktest-qt
(package
(name "go-github-com-go-quicktest-qt")