summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-28 19:58:52 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:34 +0000
commit032b497809ac06a12d21ed51a58e41389d50fb44 (patch)
treea07de6628c11778ea8bbf50a1d5c026ea0366aba /gnu/packages/golang-check.scm
parentabe86f3e7eadd044405c78cbc6fb0e1449bbfdd8 (diff)
gnu: Add go-github-com-andreyvit-diff.
* gnu/packages/golang-check.scm (go-github-com-andreyvit-diff): New variable. Change-Id: I2caa018f0451f61d9761eea474f7bf35ec5b3dc9
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 2e408226e0..d037f14d4f 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -121,6 +121,32 @@ value and call @code{t.Fatal()} if the assertion fails.")
@end itemize")
(license license:expat)))
+(define-public go-github-com-andreyvit-diff
+ (package
+ (name "go-github-com-andreyvit-diff")
+ (version "0.0.0-20170406064948-c7f18ee00883")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/andreyvit/diff")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1s4qjkxig5yqahpzfl4xqh4kzi9mymdpkzq6kj3f4dr5dl3hlynr"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/andreyvit/diff"))
+ (propagated-inputs
+ (list go-github-com-sergi-go-diff))
+ (home-page "https://github.com/andreyvit/diff")
+ (synopsis "Diffing strings in tests")
+ (description
+ "This package provides a quick and easy string diffing functions based on
+github.com/sergi/go-diff, mainly for diffing strings in tests.")
+ (license license:expat)))
+
(define-public go-github-com-bitfield-gotestdox
(package
(name "go-github-com-bitfield-gotestdox")