summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-build.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-20 00:17:14 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:11 +0000
commitdd4ee37f9af03d4dc4836d92d2ff096c8d10f299 (patch)
treec25ee8a24b059ee54d39d3718ca4c60b4ac07272 /gnu/packages/golang-build.scm
parent5e2566906aecbc6f6976befd96869b0f8b68f156 (diff)
gnu: go-github-com-golang-protobuf: Simplify.
* gnu/packages/golang-build.scm (go-github-com-golang-protobuf): Update to 1.5.4. [arguments] <phases>: Use default 'check. Change-Id: If364ed26dc2eb3006264b627696d57536c9aa7b8
Diffstat (limited to 'gnu/packages/golang-build.scm')
-rw-r--r--gnu/packages/golang-build.scm9
1 files changed, 1 insertions, 8 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index d53045372d..36bda3d48c 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -136,14 +136,7 @@ functions that have a name matched by regex:.")
#:import-path "github.com/golang/protobuf"
#:phases
#~(modify-phases %standard-phases
- ;; XXX: Workaround for go-build-system's lack of Go modules
- ;; support.
- (delete 'build)
- (replace 'check
- (lambda* (#:key tests? import-path #:allow-other-keys)
- (when tests?
- (with-directory-excursion (string-append "src/" import-path)
- (invoke "go" "test" "-v" "./..."))))))))
+ (delete 'build)))) ; no go files in project's root
(native-inputs
(list go-github-com-google-go-cmp))
(propagated-inputs