summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-build.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-22 01:15:40 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:14 +0000
commit616afc35a73c06a61e72969fae6c00c6f7a0488d (patch)
tree0c035e8234cd438956130be6051b51ee9965a0f6 /gnu/packages/golang-build.scm
parent74a939a394401c12a4019d8c2dc304497ccb4b43 (diff)
gnu: Add go-golang-org-x-arch.
* gnu/packages/golang-build.scm (go-golang-org-x-arch): New variable. Change-Id: Id0ec567e5ebfdea208fefe133a13e906e17949cf
Diffstat (limited to 'gnu/packages/golang-build.scm')
-rw-r--r--gnu/packages/golang-build.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 39949da850..4586d8e438 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -393,6 +393,40 @@ primitives in Go.")
@url{http://github.com/yuin/goldmark,goldmark}.")
(license license:expat)))
+(define-public go-golang-org-x-arch
+ (package
+ (name "go-golang-org-x-arch")
+ (version "0.12.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/arch")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "104mnfx3v6lwjndjd35ly8r6yb4bb74lq5sq1cqpxw38mqyzqmx2"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:skip-build? #t
+ #:import-path "golang.org/x/arch"
+ #:test-subdirs #~(list "arm/..."
+ "arm64/..."
+ "loong64/..."
+ "ppc64/..."
+ ;; "riscv64/..."; failed to build tests
+ "s390x/..."
+ "x86/...")))
+ (native-inputs
+ (list go-rsc-io-pdf))
+ (home-page "https://go.googlesource.com/arch")
+ (synopsis "Machine architecture information used by the Go toolchain")
+ (description
+ "This package provides a machine architecture information used by the Go
+toolchain. The parts needed in the main Go repository are copied in.")
+ (license license:bsd-3)))
+
(define-public go-golang-org-x-crypto
(package
(name "go-golang-org-x-crypto")