summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-build.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-19 19:06:34 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:09 +0000
commit2a8cb51bfc0107cfccf414e51d5caef53afff1af (patch)
tree5863ffbe8b08afdbd786119f410227e3e01852ee /gnu/packages/golang-build.scm
parent654f24934e90ac0afd212d04be50e68ad1c7624a (diff)
gnu: go-google-golang-org-protobuf: Update to 1.36.0.
* gnu/packages/golang-build.scm (go-google-golang-org-protobuf): Update to 1.36.0. Simplify package. [arguments] <phases>: Use custom 'check. Change-Id: Ia93c832e64886371f422e06e6b705c5ec3c7e05f
Diffstat (limited to 'gnu/packages/golang-build.scm')
-rw-r--r--gnu/packages/golang-build.scm13
1 files changed, 3 insertions, 10 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index bc02164cb3..a353f5d375 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -1124,7 +1124,7 @@ values.")
(define-public go-google-golang-org-protobuf
(package
(name "go-google-golang-org-protobuf")
- (version "1.34.2")
+ (version "1.36.0")
(source
(origin
(method git-fetch)
@@ -1133,21 +1133,14 @@ values.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0l18301prwy38wam9zsbhgwddwjaflvnvamghg0h1d1p201gxbp3"))))
+ (base32 "1a6l9zcm1za7w9f9n86wjszn9fm53cfacl0liyk3wpsqx4h4x6dl"))))
(build-system go-build-system)
(arguments
(list
#:import-path "google.golang.org/protobuf"
#:phases
#~(modify-phases %standard-phases
- ;; XXX: Workaround for go-build-system's lack of Go modules
- ;; support.
- (delete 'build)
- (replace 'check
- (lambda* (#:key tests? import-path #:allow-other-keys)
- (when tests?
- (with-directory-excursion (string-append "src/" import-path)
- (invoke "go" "test" "-v" "./..."))))))))
+ (delete 'build)))) ; no go files in project's root
(propagated-inputs (list go-github-com-google-go-cmp))
(home-page "https://google.golang.org/protobuf")
(synopsis "Go library for Protocol Buffers")