summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <[email protected]>2025-01-09 22:38:02 +0100
committerLiliana Marie Prikler <[email protected]>2025-03-02 20:31:41 +0100
commit70510770267fcc42e330b6dbff1b8c83951a6ac6 (patch)
tree15203a6112976a5d93df6ee9671a2d5ac7fdf140 /gnu/packages/gnome.scm
parent6d4a6e904913eb1a3678ce62196ffeb9a3298b52 (diff)
gnu: gjs: Wrap GI_TYPELIB_PATH to include necessary typelibs.
Some packages, like gnome-maps rely on being able to patch the GIRepository search path from inside gjs. For this to work, however, gjs must be able to load GIRepository, needing both glib and gobject-introspection to do so. * gnu/packages/gnome.scm (gjs)[#:phases]: Add ‘wrap-gi’.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 56b56675c6..ef84fb5d0a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7926,7 +7926,20 @@ configuration program to choose applications starting on login.")
(setenv "DISPLAY" ":1")
;; For the missing /etc/machine-id.
- (setenv "DBUS_FATAL_WARNINGS" "0"))))))
+ (setenv "DBUS_FATAL_WARNINGS" "0")))
+ (add-after 'install 'wrap-gi
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-program (string-append (assoc-ref outputs "out")
+ "/bin/gjs")
+ `("GI_TYPELIB_PATH" suffix
+ (,(dirname
+ (search-input-file
+ inputs
+ "lib/girepository-1.0/GObject-2.0.typelib"))
+ ,(dirname
+ (search-input-file
+ inputs
+ "lib/girepository-1.0/GIRepository-2.0.typelib"))))))))))
(native-inputs
(list `(,glib "bin") ;for glib-compile-resources
pkg-config