summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-09-10 12:05:01 +0300
committerJohn Kehayias <john.kehayias@protonmail.com>2024-11-05 11:56:38 -0500
commite13f4b10c5875ea4d2e174b82c5ae10985d6dfb4 (patch)
treef589e32a3afd755c3d8ae2d206cad36fa757db35 /gnu/packages/gl.scm
parent138273c4e81018c7318ba7bc6dbc5224c3c07828 (diff)
gnu: mesa: Fix build on arm architectures.
* gnu/packages/gl.scm (mesa)[inputs]: When building for an arm platform add python-pycparser. [arguments]: When building for aarch64 or armhf don't add kmsro as a gallium driver. * gnu/packages/python-xyz.scm (python-pycparser): Mark as a dependency for mesa. Change-Id: I61182157418a6667fcbb0d4280c959a708119b0d
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 1262d25137..c977c03949 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -348,6 +348,10 @@ also known as DXTn or DXTC) for Mesa.")
python-pyyaml
python-wrapper
(@ (gnu packages base) which))
+ (if (target-arm?)
+ ;; Needed for etnaviv.
+ (list python-pycparser)
+ '())
(if (%current-target-system)
(list cmake-minimal-cross
pkg-config-for-build
@@ -362,11 +366,11 @@ also known as DXTn or DXTC) for Mesa.")
#$@(cond
((target-aarch64?)
;; This includes more drivers than "auto": asahi, r300, r600
- '("-Dgallium-drivers=asahi,etnaviv,freedreno,kmsro,lima,\
-nouveau,panfrost,r300,r600,svga,softpipe,llvmpipe,tegra,v3d,vc4,virgl,zink"))
+ '("-Dgallium-drivers=asahi,etnaviv,freedreno,lima,nouveau,\
+panfrost,r300,r600,svga,softpipe,llvmpipe,tegra,v3d,vc4,virgl,zink"))
((target-arm32?)
;; This includes more drivers than "auto": r300, r600
- '("-Dgallium-drivers=etnaviv,freedreno,kmsro,lima,nouveau,\
+ '("-Dgallium-drivers=etnaviv,freedreno,lima,nouveau,\
panfrost,r300,r600,svga,softpipe,llvmpipe,tegra,v3d,vc4,virgl,zink"))
((or (target-ppc64le?) (target-ppc32?) (target-riscv64?))
;; This include more drivers than "auto": svga