summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-16 10:26:08 +0000
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:58 +0100
commit235ce649a90b395b76d21db3fa9e53e96d7749dd (patch)
treeaaf868d4c8ff7ce0aed54eb0f7c4408a10e8cbda /gnu/packages/geo.scm
parent64acec341bf279e9be92f3a1955922d404746c12 (diff)
gnu: python-maxminddb: Update to 2.6.3.
* gnu/packages/geo.scm (python-maxminddb): Update to 2.6.3. [arguments] <tests?>: Enable them as no maxmind database is required. [native-inputs]: Add python-pytest, python-setuptools, and python-wheel. Change-Id: Ie4aaa559384c75942da83afdcca0a22a7c5ced1c
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 51f772bb8b..2b8a09e047 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2460,17 +2460,18 @@ associated with an address.")
(define-public python-maxminddb
(package
(name "python-maxminddb")
- (version "2.6.2")
+ (version "2.6.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "maxminddb" version))
(sha256
- (base32
- "0r7jcqzr3hy9jims0ygjdhndysbs02hsaybx9f4vq2k2w8r2v13x"))))
+ (base32 "0m6j8pvarnw4d88537ghi1gl7nskwgkijx5c3fm4g83sm9mq1hyj"))))
(build-system pyproject-build-system)
- (arguments
- `(#:tests? #f)) ;; Tests require a copy of the maxmind database
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-wheel))
(inputs
(list libmaxminddb))
(home-page "https://www.maxmind.com/")