summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorMark H Weaver <[email protected]>2014-08-03 21:01:18 -0400
committerMark H Weaver <[email protected]>2014-08-03 21:01:18 -0400
commit8ceaf72c6d50e564d6db49479e9facbb2201c3e3 (patch)
treee558765dcfcb1c954b68f200760180d199926803 /gnu/packages/gcc.scm
parent33690ffde5af2c516bc6b2dd060ab9cf7ab88eb2 (diff)
parent684a2f59748d55de62b45c190127b704d4cdcb60 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index aed2e8925e..938c38e670 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -281,10 +281,13 @@ Go. It also includes runtime support libraries for these languages.")
(base32
"0zki3ngi0gsidnmsp88mjl2868cc7cm5wm1vwqw6znja28d7hd6k"))))))
-(define (custom-gcc gcc name languages)
+(define* (custom-gcc gcc name languages #:key (separate-lib-output? #t))
"Return a custom version of GCC that supports LANGUAGES."
(package (inherit gcc)
(name name)
+ (outputs (if separate-lib-output?
+ (package-outputs gcc)
+ (delete "lib" (package-outputs gcc))))
(arguments
(substitute-keyword-arguments `(#:modules ((guix build gnu-build-system)
(guix build utils)
@@ -302,7 +305,11 @@ Go. It also includes runtime support libraries for these languages.")
(custom-gcc gcc-4.8 "gfortran" '("fortran")))
(define-public gccgo-4.8
- (custom-gcc gcc-4.8 "gccgo" '("go")))
+ (custom-gcc gcc-4.8 "gccgo" '("go")
+ ;; Suppress the separate "lib" output, because otherwise the
+ ;; "lib" and "out" outputs would refer to each other, creating
+ ;; a cyclic dependency. <http://debbugs.gnu.org/18101>
+ #:separate-lib-output? #f))
(define-public gcc-objc-4.8
(custom-gcc gcc-4.8 "gcc-objc" '("objc")))