summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
author宋文武 <[email protected]>2025-03-09 13:43:48 +0800
committer宋文武 <[email protected]>2025-03-11 10:57:02 +0800
commit7b9cd0b4293041fdbfa065b019cea589cc316060 (patch)
tree40f1d57348abf565d957531b6476f9bce6655a9a /gnu/packages/game-development.scm
parent484ccc138a2dcde4da5d1b9a4e62404dc5d32e7c (diff)
gnu: raylib: Update to 5.5.
* gnu/packages/game-development.scm (raylib): Update to 5.5. [inputs]: Replace glfw with glfw-3.4. Change-Id: If312732d3602dc2e495c32a78fe9390642da726c Co-authored-by: Arnaud Lechevallier <[email protected]>
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 8f9a46d73e..bf4fe00828 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -3693,7 +3693,7 @@ progresses the level, or you may regenerate tiles as the world changes.")
(define-public raylib
(package
(name "raylib")
- (version "5.0")
+ (version "5.5")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3703,7 +3703,7 @@ progresses the level, or you may regenerate tiles as the world changes.")
;; TODO: Unbundle src/external
(sha256
(base32
- "0327licmylwlh5iyzw35pq7ci2d15rp3jms5i9p0vfg1rlv2sjw0"))))
+ "1dhy9ghbwvz0s434j03rfa2l6wxcfj028vlkk1xbf5q97vin5pr7"))))
(build-system cmake-build-system)
(arguments
(list #:tests? #f ;no test
@@ -3722,8 +3722,14 @@ progresses the level, or you may regenerate tiles as the world changes.")
#define MA_ENABLE_ONLY_SPECIFIC_BACKENDS
#define MA_ENABLE_PULSEAUDIO
#include \"external/miniaudio.h\"
-")))))))
- (inputs (list glfw pulseaudio))
+"))))
+ (add-after 'install 'install-api-files
+ ;; For generating bindings.
+ (lambda _
+ (copy-recursively
+ (string-append #$source "/parser/output")
+ (string-append #$output "/share/raylib")))))))
+ (inputs (list glfw-3.4 pulseaudio))
(native-inputs (list pkg-config))
(synopsis "C library for videogame programming")
(description